Wowza Community

REST-API with SSL unable to log into Wowza Engine Manager

Hello,

we’ve got our Wowza Server off site, to ensure more security I’ve configured the Engine Manager in the tomcat.properties to use SSL:

httpsPort=8090
httpsKeyStore=conf/mycertificate.domain.co.at.jks
httpsKeyStorePassword=xyz
#httpsKeyAlias=[key-alias]

The Engine Manager is working fine with the ssl connection. But as soon, as I turn on ssl in the server.xml to ensure the REST-API is connected via SSL:

<?xml version="1.0" encoding="UTF-8"?>
<Root version="3">
	<Server>
		<Name>Wowza Streaming Engine</Name>
		<Description>Wowza Streaming Engine is robust, customizable, and scalable server software that powers reliable streaming of high-quality video and audio to any device, anywhere.</Description>
		<RESTInterface>
			<Enable>true</Enable>
			<IPAddress>*</IPAddress>
			<Port>8087</Port>
			<!-- none, basic, digest, remotehttp, digestfile-->
			<AuthenticationMethod>basic</AuthenticationMethod>
			<!-- cleartext, digest, bcrypt -->
			<PasswordEncodingScheme>bcrypt</PasswordEncodingScheme>
			<DiagnosticURLEnable>true</DiagnosticURLEnable>
			<SSLConfig>
				<Enable>true</Enable>
				<KeyStorePath>${com.wowza.wms.context.VHostConfigHome}/conf/mycertificate.domain.co.at.jks</KeyStorePath>
				<KeyStorePassword>xyz</KeyStorePassword>
				<KeyStoreType>JKS</KeyStoreType>
				<SSLProtocol>TLS</SSLProtocol>
				<Algorithm>SunX509</Algorithm>
				<CipherSuites></CipherSuites>
				<Protocols></Protocols>
			</SSLConfig>
			<IPWhiteList>127.0.0.1,xxx.serverip.xxx</IPWhiteList>
			<IPBlackList></IPBlackList>
			<EnableXMLFile>false</EnableXMLFile>
			<DocumentationServerEnable>false</DocumentationServerEnable>
			<DocumentationServerPort>8089</DocumentationServerPort>
			<!-- none(only) -->
			<DocumentationServerAuthenticationMethod>none</DocumentationServerAuthenticationMethod>
			<Properties>
			</Properties>
		</RESTInterface>
		<CommandInterface>
			<HostPort>
				<ProcessorCount>${com.wowza.wms.TuningAuto}</ProcessorCount>
				<IpAddress>*</IpAddress>
				<Port>8083</Port>
			</HostPort>
		</CommandInterface>
		<AdminInterface>
			<!-- Objects exposed through JMX interface: Server, VHost, VHostItem, Application, ApplicationInstance, MediaCaster, Module, Client, MediaStream, SharedObject, Acceptor, IdleWorker -->
			<ObjectList>Server,VHost,VHostItem,Application,ApplicationInstance,MediaCaster,Module,IdleWorker</ObjectList>
		</AdminInterface>
		<Stats>

I get the following message, after entering the credentials.

Wowza Streaming Engine Manager could not connect to the Wowza Streaming Engine service(http://localhost:8087). Verify that the Wowza Streaming Engine service has started and is running.

Are ther any other settings missing, to ensure the Streaming Engine Manager uses https?

Thank you, best regards
Gerhard

You can check our troubleshooting article for this exact error in our FAQ page.

https://support.wowza.com/hc/en-us/articles/1260803011850-I-Can-t-Login-to-Streaming-Engine-Manager

You’ll need to check you’re using the correct ports as explained in the article. SSL requires its own for example.

Hello,

the streaming engine is up and running (I can’t play around on an productive environment, therefore I use a trial Licence for this server)

netstat seems to be ok, 8088 and 1935 are listening

Should the 8087 Listen?

root@wow:/etc/shorewall # netstat -an | grep '8086'
tcp        0      0 0.0.0.0:8086            0.0.0.0:*               LISTEN
root@wow:/etc/shorewall # netstat -an | grep '8087'
root@wow:/etc/shorewall # netstat -an | grep '8088'
tcp        0      0 0.0.0.0:8088            0.0.0.0:*               LISTEN

Firewall for 8087 is open.

Thank you for your help!