Wowza Community

RTMP Cerevo Liveshell X problem


Since last August we have experienced some problems with our RTMP stream and the Cerevo Liveshell X encoder.

When streaming the RTMP stream the stream will stop after several seconds and after some seconds the stream will start again. This process of start and stop will go on as long as the stream is live. When we record the stream there are no ‘start and stops’ in the playback.

We have tried to watch the stream on Windows/IOS and Android devices but all the devices experienced the same problems.

Before August we had have no problems.

Our Liveshell X has the latest firmware and the Wowza server is updated with the latest security patches.

At this time, we have downgraded from the Liveshell X to the Liveshell Pro

With the Pro version we have experienced no problems.

We have discussed this with Cervevo and Wowza but we are still facing this problem.

Can anyone help us out?

Kind regards,

First thing I’d check: anything in the logs on either side? And if you have discussed this with Cerevo and Wowza, what was their conclusion?

Yes, we have checked the logs and it seems that are some struggels in the logfile of the liveshell.
This is discussed with Wowza and Cerevo but they are pinpointing it to each other.

Before August the where no problems.
The firmware of the Cereve was installed in february so it is unlikey that there is a problem with the firmware.
We’ve also tried some other Liveshell X encoders and they all give the same problems.

Could it be usefull if I post a logfile?

I don’t know if this is your support ticket or not, but I did see this information that was provided by Wowza engineers for a similar issue with Cerevo Liveshell X:

"If the issues are occurring at the source, it could be that the HLS stream is being filled with discontinuity tags and the Andriod devices are not handling these tags/messages well.

When playing the stream using Windows with JW Player, you’ll be able to view the browser logs and check the Network tab and the Headers for the chunklists to see if they contain any EXT-X-DISCONTINUITY tags.

If so, there’s nothing that can be done on the Wowza Streaming Engine side as adding these tags is part of the Apple HLS spec. Any player devices would need to be updated to be compliant."


I have checked the network and headers for the chunklits to see any EXT-X-DISCONTINUITY tags.
Neither the network and headers contains EXT-X-DISCONTINUITY tags.

Are there any solutions to solve our problem?


Just a update received form Cerevo:
We’ve been closely reviewing your reported issue and we discovered that we do not hear any similar situation like yours from other Wowza users from around the world in the last 3 or 4 month. Because you informed us that you don’t see the same issues when you do live streaming by using YouTube, we believe that the situation you shared with us is something to do with your Wowza setting. Unfortunately we do not have any control to find out about what Wowza updated/changed the service and we kindly suggest contacting Wowza for details. We are sorry to tell you that we see your situation is something out of our control.