Wowza Community

RTMP playback delay on vlc increases overtime

please help …

i’m trying wowza to send a RTSP stream from an android device to other LAN clients

i’m using VLC to play the RTMP stream as a client

when starting a playback … the delay is < 1 second and that’s really really great

but overtime the delay keeps increasing … sometimes when i leave the streaming ON … for about an hour or more …
the delay reaches 5-7 seconds !!!

but when i stop the VLC playback and start it immediately the delay return back to it’s first state (< 1 second)

i almost tried everything

  • i tried setting cache to low value in VLC but that decreases the instant delay … not that accumulating dela

  • i tried to decrease the bitrate of encoding … i even set it to 10 kbps !!!
    i knew that the quality would get so bad but i wanted to test the theory that it’s just a
    bitrate vs bandwidth issue … also didn’t work … it’s barely the same

  • i tried setting the stream type to (live-lowlatency) in the conf of live application (application.xml)

  • i tried a tip that was mentioned before in another question … by adding those properties in the xml too

instantOn true Boolean

instantOnBufferTime 3000 Integer

but all leads to the same issue … i can’t get rid of that accumulating delay please if anyone can help

try to setup buffer = 0

Ahmed, did you get any solution yet? I am also interested in this issue.