Wowza Community

RTMP-stream periodically fails with publish/unpublish events pair in logs

Hi guys.

I have next problem: my own flash streamer capture stream from USB camera using Camera API and starts publishing to Wowza application. Its all ok, clients can connect to this stream and watch with own flash player, no errors or other issues, in Wowza error logs is also nothing interesting about given stream. But, in some situations, my stream stops for a seconds, and after recover again, clients are reconnected after. In Wowza access logs I found this:

2015-07-23 07:34:31 UTC unpublish stream INFO 200 %streamName%- defaultVHost origin definst 983.154 [any] 1935 rtmp://%wowzaUrl%/origin/ rtmp %URL here% WIN 18,0,0,194 845927967 89513353 6275 1 0 89409092

2015-07-23 07:34:32 UTC publish stream INFO 200 %streamName%- defaultVHost origin definst 984.814 [any] 1935 rtmp://%wowzaUrl%/origin/ rtmp %URL here% WIN 18,0,0,194 845927967 89513417 6447 1 0 89409092 0

This is not an Internet connections issues (or VPN), not a camera issue (we tried 4 different), not a timeout in Wowza or proxy (test without proxy), balancer (publish is direct to single Wowza server).

So, what that can mean and what’s going on here? :slight_smile:



Hi Mary.

I would suggest starting Wowza in stand-alone [install-dir]/bin/startup.bat|] mode to monitor the server activity.

This may paint a clearer picture of what is happening when the stream is unpublished.



Mary, I was just coming back to this post to tell you that you would be looking for messages in the console rather then the logs, when I saw that you responded already.

Sorry I forgot to mention this in my first reply.

If nothing of any significance shows up in the console, you may decide to open a ticket with support by emailing Please include a zipped copy of your /conf and /logs folders, as well as a link to this thread for reference.



Hi salvadore.

I’m already tried this, the problem still reproduced, and nothing interesting in logs.