Wowza Community

rtp-live + JWPlayer


I set up the first Instructions from the Tutorial How to publish and play a live stream (MPEG-TS based encoder) for Flash only. I used a Hardware encoder and everything works fine with the Sample Client under [install-dir]/examples/LiveVideoStreaming/client/live.html with

Server: rtmp://localhost/rtplive


My containts udp://

Now I tried to use JWPlayer 4 or 5 instead of the sample above but I didn’t get the Totorial Using JW Player 5.x with Wowza Server or Using JW Player 4 with Wowza Server working with JWPlayer 5.7 or 4.6 for my Setup.

It seams that the File isn’t working …

I want to have minimal buffer length and autoplay since latency is important.

In JW Player 5, be sure to add provider=rtmp

Flashvars = "streamer=rtmp://localhost/rtplive&"


If Wowza is running as a service, stop the service and run in stand-alone (/bin/startup.bat) so you can see log output. What do you see when you click play? If nothing, then you are not connecting to Wowza. Maybe the port is not open. Otherwise there should be some useful log output


Forgive, I badly write in English. But I will try to help you

I think, JW Doesn’t begin network activity it will not be convinced yet of a correctness of the name of a stream - not the correct name - is correct name

Such here Hack :slight_smile:

In my case the connect line looks so


But my realy stream name is a -

It works good !

From russia with love!

Hi, my html-File looks like this:



I use version 5.7 of JWPlayer. I see the Player and if I hit play it shows the Message “Could not connect to application Error #2028” for some millisecs.

After that the “loading Symbol” starts spinning and nothing more happens.

I switched to live because I now tested the second Application with support for all technics. I also tried to use localhost without a port… or using the LAN Adress of my server…