Wowza Community

RTSP onDemand/Live Streaming using Wowza 2.2.3


I am an avid user of Wowza and have recently upgraded to Wowza 2.2.3.

I am trying to do an RTSP onDemand and Live broadcast, I am using Wirecast for the live broadcast.

With both onDemand and Live I get the audio and not the video. This is also the case with the Wowza Demo: rtsp://

I have followed the following instructions to the letter and still only get the audio even though both audio and video are available:

Any suggestions?

Thanks in advance,


What player are you trying to use and on what platform?


There is a good chance that Real Player will not work. Real player is spotty.

For QuickTime player you must turn off acceleration:

The other two should just work. I have an Android with 2.1 and it works great. Blackberry works as well. Try again our test stream:


Then it is most likely a UDP routing issue. For some reason UDP is not able to traverse your firewall/router. I might try running your mobile device on a different network (behind a different router/firewall). Unfortunetly, Android only support RTP over UDP. Which can be a problem with some network setups.



Have you enabled port 554 (default rtsp port)? If not, use port 1935:


To use port 554, change /conf/VHost.xml /HostPort /Port from “1935” to “1935,554”. Then restart Wowza.

Then this can work:



Oh, I assumed that was yours. Yes, the Wowza demo does have 554 enabled.

That page use html anchor (a) tags and rtsp urls. Do the videos on that test page play in the device you are testing when you open that html page?


Hi Charlie,

I have tried using Real Player 11.1.3 & Quicktime Player 7.6.9, both on Windows 7 And Vista.

I have also tried on the Android 2.1 and the Blackberry Storm (I think it is the 9500).



Hello Charlie,

OK, maybe I am doing something very wrong. I still cannot get the streams plaing in the Android or Blackberry. I was, and am, using the swowza streams:

Also, I have created an HTML page with the following. When I open this using either the Android or Blackberry it will not work:


Thanks again,


Hello Richard,

Thank you for your reply.

Yes I have already enabled port 554 on our server. What is interesting is the URL: rtsp:// is one of yours found in your example page:

We have the same problem with our wowza server and resorted to one of your streams and found the same issue?

Thanks again,