Wowza Community

RTSP stream closes after five minutes when viewing with VLC media player

Trying to use wowza to stream media between users over RTSP. Found that after exactly 5 minutes, the stream will fail (only via RTSP- RTMP works fine). The relevant error that VLC logs is
“live555 warning: no data received in 10s, eof ?”
Thought that it could be something wrong with our configuration, but the term “300000” does not appear in our configuration anywhere, and most importantly, opening VLC Media Player and playing the wowza example stream results in the same 5 minute failure.


I also found a link describing a similar issue that might be relevant, but it is pretty dated.

I also tried looking at the traffic in wireshark and saw both RR and SR RTCP traffic. But when the five minute mark hits, UDP traffic halts, and ten seconds later I get a “Goodbye” RTCP RR, seemingly with no other relevant traffic before or after. In other words, Wowza stops sending stream data after exactly five minutes, and live555 rightfully shuts down.

In the engine manager, the source stream never stops or goes down. but I see that outgoing connections stop after five minutes. If I set the client up to reconnect, I can see in the engine manager that the outgoing streams goes up and down every five minutes on-the-dot. It is perfectly consistent.

Why is wowza timing out after five minutes? Is it ignoring the RR’s from live555? If so, is this 5 minute timeout configurable? If not, is live555 failing to do something that wowza requires in order to acknowledge that it is still listening to the stream?

Did you check to see if you have a firewall blocking this connection? Do you have the proper ports open? If both are fine, then it may be your DNS timing out- that could trigger this issue.

  • DNS issue that is timing out- you can run a ping test to see if this working correctly.

  • Make sure you are not using a private IP address and that it is routable outside your local network.

  • If you can connect to port 1935 when opening a browser directly on the server then that points to a network issue.

There is a similar post in the forums today. Is this related to

I don’t think it’s related. I am seeing this issue only with RTSP. I tested with my DNS set to and watched the Wowza sample rtsp stream at


It still disconnects at exactly 5 minutes. Seeing as this is occurring on Wowza’s own test stream, I would imagine that it’s not an issue with firewalls or ports. Also, the stream works fine for those first 5 minutes, which I wouldn’t expect to occur if there was an access issue.

I tested that RTSP URL, and for me it does not disconnect. I suspect that it’s either something with your network connection, but more likely your machine. Does the problem occur on other networks? Does the problem occur with another machine on the same network? Is there a problem with the VLC version you have installed?

If you have the same error on your own Wowza installation, then check the Wowza logs, maybe it tells more about the reason for disconnecting.

Or maybe VLC is just generally tired of playing Big Buck Bunny - it must have done that a zillion times worldwide now …

I tested on another network and it appears to work… strange. I’ll look into why this would happen when I get a chance. Thanks for taking the time to test it.