Wowza Community

RTSP Video not detected

im trying to pull an RTSP feed from a MATROX maevex encoder and im not having any luck with WSC latching on to the stream. i’ve tried pulling it as an" IP camera "and as a “other RTSP” in the video source and transcoder settings tab. I know the feed is live since i can pull it on VLC with no problems.

the feed is not protected and it does not have any user name or passwords attached.

Any help would be greatly appreciated it.

Can I see your playback url that you’re using?

Here is a RTSP troubleshooting doc that may be helpful too. I see a lot of people have issues with the video and audio being out of alignment.

Hey Rose , thanks for the quick reply .

i took a look at the link you sent me and modified my transport mode but im still not having any luck with the stream

That was a local IP address that you shared and won’t be recognized by a remote server.

That was a local IP address that you shared and won’t be recognized by a remote server.

Hey Rose sorry about the confusion

My Playback URL is

My source URL is


I modified my transport mode to UDP to see if that would do something but i had no luck


To access your encoder from the Internet, you will need to identify your public IP address and configure your router/firewall to forward outside requests on the applicable ports.

You (or a network administrator) must access your network firewall to open and forward these ports to your encoder that is on your local network. This is not a process we are able to support, however, this website,, provides all sorts of instructions for various routers.

Once your port configuration is completed, from a computer on the same network as your encoder, you can visit where your public IP will be displayed. In most situations, using your IP will direct you to your encoder, again, as long as the ports are open and forwarded correctly. You may also add a domain to your public IP or use a dynamic DNS updater (i.e. to keep track of IP address changes if you do not own a static IP address.

Once you’ve made these changes, you can test if the encoder is accessible from the Internet. Using a computer that is outside your firewall, try playing back the encoder source stream in vlc again using the public IP address (example) [rtsp://PUBLIC IP HERE:port/streamname].

You should see your source stream. If you do not see playback, you will need to re-confirm your network security settings or the actual RTSP URL generated via your encoder.

I hope this helps clarify what is needed to pull your source stream into Wowza Cloud.