Wowza Community

Server level property to enable WebRTC missing

After installing the WebRTC Preview addon on a server, I tried to use this link to test if i can publish a stream

When I try to publish it, I got the following error: “Server level property to enable WebRTC missing” and in console tab I got this log “wsConnection.onmessage: {“status”:512,“statusDescription”:“Server level property to enable WebRTC missing”,“direction”:“publish”,“command”:“sendOffer”,“streamInfo”:{“applicationName”:“webrtc/definst”,“streamName”:“test”,“sessionId”:”[empty]"}}"

And in the server logs

#Fields: x-severityx-categoryx-eventdatetimec-client-idc-ipc-portcs-bytessc-bytesx-durationx-snamex-stream-idx-spossc-stream-bytescs-stream-bytesx-file-sizex-file-lengthx-ctxx-comment

WARNservercomment2018-03-0202:03:51-----252695.467--------WebRTCCommands.sendOffer: Server level property to enable WebRTC missing

WARNservercomment2018-03-0202:06:24-----252848.289--------WebRTCCommands.sendOffer: Server level property to enable WebRTC missing

WARNservercomment2018-03-0202:08:37-----252981.55--------WebRTCCommands.sendOffer: Server level property to enable WebRTC missing

WARNservercomment2018-03-0202:08:47-----252991.369--------WebRTCCommands.sendOffer: Server level property to enable WebRTC missing


Thanks for contacting the Wowza Community.

Can you confirm you following the configuration steps in this article?



I have followed this tutorial

Wowza WebRTC Example


Thanks for the confirmation. Can you open a ticket HERE

Can you please send the below support folders to further review your setup along with enabling the WebRTC debug logging in [install-dir]/conf/[app-name]/Application.xml:

webrtcDebugLog true Boolean

Save and restart your application for changes to take effect -> Then try connecting again with WebRTC publish.

[install-dir]/logs (only latest logs are needed showing a Wowza Server restart and connection attempts)
If you are not sure how to get this information please see the following tutorial.

If files are too big for email transport (20 MB), please send a downloadable link to the files.



have you resolved the issue? I have the same too, I would like to know the solution.

Thank you

Best regards


Hello, have this issue resolved? I have the same also.

Enable the preview.
To do this, edit [install-dir]/conf/Server.xml and add the following property to the container at the bottom of Server.xml: webrtc76de5tceo3l18xdh9e7ga true Boolean

does anyone tried Carlos Ferreira’s answer?

Yes its working.

This answer is spot on. You may also need to restart the server after changing this file.