Wowza Community

Server Not Found - RTMP blocked by proxy??


I’m trying to troubleshoot a problem we have with viewing content from a vendor. The vendor is running Wowza Media Server 2 and serving us content via RTMP (i.e. rtmp://:1935/vod) using JW Player 5.2.1151

From within our network we get a “Server not found” error, but from external to our network we can get to the content.

However, I can view your demo at

Any ideas on what might be going on? Anything I should be checking?

I thought our proxy server mightn’t be able to handle rtmp, but I can get to your demo.

Hello Alex_D,

This is the key piece of info: “From within our network we get a “Server not found” error, but from external to our network we can get to the content.”

If wowza is listening and your network is not blocking port 1935 you should be able to telnet to port 1935 like this:

telnet localhost 1935

Desired response:


Connected to localhost.localdomain.

Escape character is ‘^]’.

When Wowza is not running you’ll see:


telnet: Unable to connect to remote host: Connection refused

Replace “localhost” in the telnet command with your Wowza server’s IP.


Your network admin should be able to tell you what the correct internal address is.


I think TCP port 1935 is block in your server or router, or Wowza is not running. You can check in a browser, this should return Wowza version and build number:

Your server is reachable on port 80


You have a web server using port 80 already, so if you added port 80 to /conf/VHost.xml and re-started Wowza, you are going to see many errors in the access and error logs saying that Wowza is unable to bind to port 80. Undo that change and re-start Wowza, or stop the web server on that machine and re-start Wowza.

The best solution is to open TCP port 1935 in your firewall, and router if necessary.



Seems pretty snappy to me.

I tested your stream:

In my test using the Wowza example OSMF player it starts fast and seeks fast. If you are using another player, try the Wowza example SimpleVideoStreaming clientOSMF

Works good in Flash Media Playback too:

Select “yes” under “Are you using HTTP Streaming or Flash Access 2.0?”, then paste in your URL and Preview



Yes that link does use port 1935. And you said your link “rtmp://:1935/vod” is working on port 1935 from outside your network. But you cannot access that IP/Port from inside your network. It’s a network problem you need to figure out… Check your firewall/proxy configuration.

hello poojan206,

HTTP streaming over port 80 is really easy. Just edit your VHost.xml and change 1935 to 1935, 80. Then play using something like this:

http://[Wowza IP]:80/vod/sample.mp4/manifest.f4m

There is also the RTMP Tunneling options. You’d have to edit the flash script found here to change port 443 to 80:

Looks right to me.

I have several suggestions.


  1. Restart Wowza after making changes to conf files.

  2. Get it working in the OSMF player before trying JWplayer: [WowzaMediaServer]/examples/SimpleVideoStreaming/clientOSMF/bin-release/SimpleOSMFPlayer.html

Don’t use your own video file. Use the sample.mp4 that comes with Wowza.



  1. If your content is in /var/www/html you need to change your StorageDir element in your conf/vod/Application.xml to:


Make sure your sample.mp4 file is in the directory specified in the StorageDir element.

Have you done that?

  1. Please post your firewall settings here. SSH into your box, and do “sudo iptables -L”.

  2. Post any Wowza console errors, or log errors here.

Thanks for the reply Randall. I am getting “connection refused” for the Wowza server.

I’m not sure if this is relevant, but the Wowza server is not on our network - its hosted externally.

Is the demo on using port 1935? If not, are there any demos or sites that are using this port that I could test against?

Thanks again for your help!

Thanks for your help on this guys.

The server I’m trying to access is hosted externally. Totally off our network. It shouldn’t need an internal address. I guess it must be a network issue.

The bit that I don’t understand is why I can get to your demo (using the same port/protocol) but can’t get to this other one. If it was a firewall/proxy issue, why can I still get to your demo? Wouldn;t it be blocked as well??

I am also getting the same error I am using JWPlayer to play the video. I have a remote VPS. When I started WowzaMediaSevrer and then tried telnet localhost 1935 on my server, I got ‘Connection refused’.

Does this mean that port 1935 is blocked on my server. Is there a way to change the port.

My code is as follows:

var flashvars = {







Please help

I tried and the browser not able to connect. I think this means that the port is disabled. I have started Wowza on the server by ./

Port 80 is working. Is there a way to stream on port 80?

thank for your reply

My WowzaMedia Server is installed in /usr/local/ and is in /var/www/html/ directory.

Should I write ‘http://[Wowza IP]:80/vod/’ in the ‘streamer’ option or the ‘file’ option? Sorry for asking such a silly question

I tried adding 80 in VHost.xml and tried the following thing:

var flashvars = {






But i still get Server Not found

Thanks now it is working fine. I just opened the 1935 port and copied the video file in the content folder and it is working fine .

Just one more question. I dont know if this is relevant. When I click on some time, it takes sometime to go to that point. Is there a way to decrease the time?