Wowza Community

SRT transmission between wowza servers

good afternoon.

I currently have 2 wowza servers, and I need to stream video from one server to another via SRT.
Server A is the one with the source video.
Server B is the one who receives the transmission.
Server A was configured according to:
Server B was configured as:

Despite following the mentioned links, it does not work.
What is the default port used by Server A for SRT protocol?
The configuration has something bad
From Server A there is communication to B, and from B to A, it is checked by running PING on the network.









Did you mean to post images of your configuration? They don’t seem to have come through the post.

Make sure you have matching ip and port specified in your .stream file on server B and your SRT stream target on server A. Also make sure you “connect” the SRT mediacaster on server B before starting the stream on server A (order matters!)

If you are trying to use a passphrase, try without that first.

Let me know if any of this works for you!

Attached image of the configuration of both servers. Cannot establish communication, servers have public IPs.

I already tried it without a password, and the same thing happens.

Server A (which transmits), has configured the IP and port (10000) of server B in Stream Target.

Server B (which it receives), has a .stream, with URI rst://serverA:10000,

See these images:

How can server B listen to port 10000?

Please change…in server A use

The Sever ip of B

and in Server B use


Also note the udp ports are 9000-9999

Use the order you indicate, without success. =(

OK, do it as you indicate, and it doesn’t work.

Thank you for your comments, but I’m not successful yet. I attach configurations of both servers. You are working without a password. Any suggestions?


Does SRT work on public IP networks? both wowza servers are with public IP to the internet. Test on SERVER A, to transmit and receive the same SRT transmission (with the localhost IP), and it works. But when working with public IP, Server A does not connect to server B. When doing PING to the public IPS of both servers, they respond correctly.



Using the process I explained… I successfully connected

Yes it works on Public ips…

Can’t tell you how much we appreciate you here at Wowza @Egbert Williams. Thanks for helping.

@Egbert Williams

Trying different streams, I noticed that sometimes the state was in error, but he is not able to connect to server B.

In your successful case, with what transmission do you feed the server? In my case I have a file stream, which points in HTTP to my IP headerTV, and in which I use AppleHLS medicaster. Try all the mediacaster and with none works, only with AppleHLS is it able to display the ERROR message, with the others there is an waiting message.

I am sending a stream from vMix using RMTPS to ServerA. I suggest you use OBS in this test phase just you get it working. Also check your server to see which ports are open to udp…I believe between 9000-9999 you are safe

@yonathan lagos I notice that the status on server a SRT target is waiting. That suggest that there may not be input from its source.

Thank you very much to all.

The problem was, that on the side of Server B, wowza is being used with docker. Docker requires mapping ports. For this case, 2 ports 5454 and 5555 must be used both in UDP.

As documentation here information to use docker with wowza:

And finally to map the ports indicated above should be used --expose 5454-5555/udp --publish 5454-555:5454-5555/udp

Thanks for coming back and updating this thread on how you fixed it.