Wowza Community

ssh access to wowza EC2 instance

The documentation describes how to set up the puttygen.exe for ssh telenet access to the wowza insance running on EC2. I am using Mac OSX, so I want to directly ssh into my wowza instance. I have generated the private key using elastic fox keygen.

My question is: how do I configure my terminal to be able to ssh into my instance of wowza EC2 server. I am quite familiar with ssh access. I am assuming if I use keyed access then I don’t need username password authentication since it uses public/private keys right? So when I used Elastic Fox to generate key pairs, I got my private key and Elastic Fox must have copied my public key on to my instance of the server?

So I guess my question boils down to “how should I configure my terminal to pick up the private key generated by ElasticFox” ?

Thanks for your time.

Gentlemen (SysOps),

We have paid for our subscription for Wowza on EC2. The server is set up and I am trying to hook it up with our S3 storage. It seems like your how to guides are geared towards “putty”. I have been using linux and Mac OSx. Currently I am on a Mac OSX machine. Will you please show me how to enable terminal access to Wowza instance running in EC2?



A quick google on mac os x ssh ec2 reveals this.

ssh -i [your private key].pem root@[your ec2 address]


I think you can use the SSH client (terminal) that is included with Mac.

You have to enable port 22 in the EC2 Security Group.


If you are using putty, you need to use puttyGen to turn the pem into a ppk file. See this guide:


You’ll also need to change the permissions on the keys in ~/.ec2 to 0600 - that’s what’s causing the error you’re seeing. Having them world-readable is the security hole it’s trying to prevent.

Hello Richard,

I tried to do just that but I get access denied error. I have enabled port 22 in EC2 security group as advised but no luck.

In desparation, I installed Mac version of putty and followed the instructions in the guide and it worked! But being able to use terminal on a Mac or Linux machine is a much superior experience than putty, don’t you agree?

If someone at Wowza can write up simple instructions on how to enable terminal access for Mac OSX and linux machines that will be a hugh help.

After all, my EC2 Wowza machine instance is a Fedora 8 machine. Having to interact with it using the primitive putty on either a Mac or Linux machine is a disappointing experience.


Thanks Roger. It works.



Doesn’t work for me. Getting a “Warning Unproteceted File Key” Permissions 0644 for ‘/Users/jvalali/.ec2/’ are too open.

It is recommended that your private key files are NOT accessible by others.

This private key will be ignored.

bad permissions: ignore key: /Users/jvalali/.ec2/.xxx.pem

Permission denied (publickey,gssapi-with-mic).

Help. Been trying to connect to this sever for 2 days.