Wowza Community

Start recording - "Start is not allowed!"

After I started a transcoder, I tried to start recording via{id}/start_recording

but response was

  "meta": {
    "status": 422,
    "code": "ERR-422-InvalidStateChange",
    "title": "Invalid State Change Error",
    "message": "The request couldn't be processed. Start is not allowed!",
    "description": ""
  "request_id": "e9a083ee8d056a12c4ae37b06c52fcde",
  "request_timestamp": "2020-07-10T10:54:48.017Z"

I tried with both transcoder_type: passthrough | transcoded but no luck…

Also, createTranscoder api has recording: boolean field, but documentation says



This parameter is sunset and no longer available.

and it seems simply ignored (even if I specified recording: true, no recordings are started when I started the transcoder)

I confirmed that no recording is running via


Can someone help me to start recording?

Self solved, I just need to specify

properties: [
    "section": "recording",
    "key": "mp4",
    "value": true

on creating transcoder, then no need to manually start.

Also, recording will be created after the transcoder stops. So don’t worry if you can’t find any recordings while transcoder is running.

Thanks for going back in and sharing the solution with the community.