Wowza Community

Stream target Facebook Live

When you finish your live broadcast and then for some reason you decide to eliminate that transmission from your wall, and start another, WOWza shows “Error” of facebook stream target.
the only way to work is to edit the description, and return to save the description text for a new or different, apparently does not renew the token.

In previous versions renewed in each new broadcast.

Anyone have the same issue?

Hello Claudio,

I would like to take a closer look at the error you are reporting.

Please submit a support ticket and include the zipped contents of the following directories:

[install-dir]/conf/, logs/, transcoder/ and manager/logs

Note: We only require the last 10 days of logs, which shoudl keep the requested data set below the maximum upload size for our ticket system


Jason Hatchett

Sorry, i cant open a support ticket because my license has support expired, but its happens about 10 days ago. when i upgrade the wowza to the last

The Log show:

This error is now because one video customer has deleted the Video Post Wall Facebook live…, so… i have edited the Descripction of the Stream target to new one and now its works again…

Hi Claudio/Jason,

Yes we have noticed the exact same issue with the latest version of Wowza Server ( (build 21295)). I have a open ticket with Jermaine Hemby (#267966). We’ve been going back and forth for about 3 weeks and sent tons of logs to Wowza. From his last email it sounds like Wowza has identified this as a bug and it will be fixed in the next version. Hopefully soon.

We have two time critical broadcasts to FB that use Stream targets to bounce the stream to FB and they often (70-80%) of the time error when the incoming stream shows up, and YES – other than one time when it did not work at all – the edit/save trick seems to re-request a new token from facebook which makes the target work properly for a while.

The worst part of it is that we have not been able to figure out a pattern here. Sometimes the edit/save thing works and all subsequent start/stops keep working. Sometimes the edit/save works once and when the stream stops and restarts the target goes into error mode again – requiring a edit/save kick.

Also worth mentioning is the fact that through some voodoo (literally) this process has been running flawlessly without error for the past 3 days (knock on wood)…but I’ve seen enough “error” states on the FB stream target for the past 3-4 weeks to know that there is a serious bug in the code somewhere…hopefully a fix will be released soon…getting really tired of baby sitting stream targets to make sure they don’t error.

Thanks for sharing, even though you don’t have a contract…atleast I now know I’m not the only one having the issue.


Many Ayromlou

P.S. Just noticed that Server 4.7.4 is out…going to give it a try now…cross your fingers :-).

Hello! thanks for the answer! maybe the only thing we can do now is… wait for a new version and bug fix. :slight_smile:

Facebook Streaming Target Error, I configure perfectly, but still It throws error. Please help me

try to change the description and title on your target stream facebook created, and save changes.
Try to connect again. its work for me.

Same problems here:

  1. After Last Wowza Updates 4.7.4 Facebook Target Error on all applications

  2. After Last Wowza Updates 4.7.4 DVR is not functional on smil files or transcoded applications on JWPlayer.

Thanks for sharing your answer… im still use 4.7.3 and from time to time I renew the descriptions of the stream targets … and with that I am partially solved

Update 4.7.4 also broke my Facebook Stream Targets to a Page. Just updated to 4.7.5 and still have an error to stream to a Facebook page.

The only workaround I have figured out is to create an event and then stream to that event.

Hello Michael,

With Wowza Streaming Engine 4.7.5 there’s additional properties that can help when publishing to a page.

This will help decrease the chances of a timeout when connecting to Facebook’s API.


-> App level properties at the end of the file:


Save and restart your application when making changes.

*If 12000 does not work, please try 15000 (15 seconds).



That worked! Thank you Jason so much! You are a life saver.