Wowza Community

Stream Target Facebook without logging into FB

I have been able to use the “custom RTMP” to send a stream to FB. But, that does not seem to be working any longer. I am not sure what has changed. I am using a newer version of Wowza, on the EC2/Amazon network… 4.7.8… I believe FB now requires an RTMPS (S!) stream, that’s a firm requirement at this point.

How do I use the info in the traditional send-to “URL” and “streamkey” to initiate a push to FB. That is all I want to do… All the documentation suggests “log into FB”, but I don’t need to, don’t want to, if I have the URL and streamkey, that’s all I should need…

persistent key: 1991679414457928?s_bl=1&s_ps=1&s_sw=0&s_vt=api-s&a=XAbzICCqwgvXQqniy server URL: rtmps://

Any input or thoughts would be greatly appreciated!

We can assume then you have an SSL certificate to stream RTMPS?

It is also possible to enable the RTMP stream target to send RTMPS content to the destination. Open the

[install-dir]/conf/[applicationName]/PushPublishMap.txt file in a text editor, find the entry for the RTMP stream target in the map file, and add “sendSSL”:“true”.

Please see the post and feel free to search RTMPS to FB with API in search bar for several posts on this. Thank you…

Rose - thanks for the info, still not working though…

I worked hard to get FTP working with authority to adjust the PushPubishMap.txt file (needed to adjust security, a pain for someone that does not know Linux or SSH/Putty, etc)…

Updated per your suggestion, restarted the application, checked all the settings, confirmed the update was made, still not working… Stream Target reads an “error” when trying to push to FB…

Here is the contents of the PushPublishMap.txt now…

#myStream={profile:“rtmp”, streamName:“myStreamRTMP”, host:“localhost”, application:“live”, userName:“myuser”, password:“mypassword”}

#myStream={profile:“mpegts”, streamName:“myStreamMPEGTS”, host:“”, port:10000, rtpWrap:false}

#myStream={profile:“rtp”, streamName:“myStreamRTP”, host:“”, videoPort:10002, audioPort:10004}

GTB={“entryName”:“GTB”, “profile”:“rtmp”, “application”:“rtmps”, “port”:“443”, “sendSSL”:“true”, “destinationName”:“rtmp”, “host”:“”, “streamName”:“10220824507501939?s_bl=1&s_ps=1&s_sml=3&s_sw=0&s_vt=api-s&a=AbzR7QBX-XXXXX”, “enabled”:“true”}

What am I missing? This should not be this difficult…

Thanks in advance!

(changed the streamname in the body of this message for security reasons).


GOT IT WORKING! Changed “application” to RTMP from RTMPS, did the trick… Rose, thanks for the help!

Hello William,

  1. Please ensure your Wowza Streaming engine is fully updated to the latest available update.

  2. When using the Stream Key have you verified there is no firewall blocking rtmps on 443?

  3. You will have to log into Facebook even when using the Stream Key as this method only gets you to a “Preview” state in the Facebook side interface, you will still have to hit “go live” in Facebook.

  4. Please feel free to submit a support ticket so we can dig deeper into the error you are receiving:

  5. The only way to not have to log in to Facebook is to create your own Facebook Side app, which would be similar to our Wowza Streaming Engine, Wowza Streaming Cloud and ClearCaster Application, but this does require a good deal of development that is outside the bounds of what Wowza’s Support team can assist with as this is development for a 3rd party platform to obtain security rights to broadcast and you still have to meet end-user privacy and security requirements and get your app approved by the team at Facebook.

    That being said there are others in this community that have done this and may be able to provide assistance in the Forums.

    Jason Hatchett
    Technical Support Supervisor – Wowza Media Systems

I did find I could edit the txt config file that includes the stream target info, I set SSLsend to true… and, that fixed the problem…

And, I could use my solution WITHOUT having to log in to FB. So, point 3 above it WRONG. And, point 5 above is also incorrect/wrong.

You all are having trouble keeping up with FB, really? Having to log into FB is, would be, a real limitation for video producers that works with many different clients…

I did get better support from


You’re welcome!

Thanks for the honest feedback William. It is possible that something has changed, but we partner directly with FB and that is the latest information we have. The engineers want me to ask you if you started the signal in Live Producer in FB. We’re happy to dig deeper with you in a support ticket too if you’d like.

Our engineers just ran a successful test, so if you’d like, we are happy to look at the steps you took in a support ticket. I want to make sure you feel content with the support we do have available.