Wowza Community

Stream to Samsung Connected TVs

Hi Everyone,

I’m working on a solution to re-stream a live rtmp feed to Samsung’s new web connected TVs. Has anyone been able to successfully do this? If so what method did you use?

It’s my understanding that the TVs can receive rtmp streams via a Flash based widget but I haven’t had any luck using the Samsung SDK to get it working. As far as I can tell they don’t support rtsp or iPhone type streaming which is a shame! The TVs do have support for h.264 and I’m able to get VOD mp4 files delivered just fine but we want to build a live app.

I have been able to plug in a mms live stream and was able to get that to work but in this case I’m trying to re-stream a rtmp stream so that doesn’t get me very far.

Anyway I’m hoping that maybe someone else has solved the issue and they can share how they did it. Thanks in advance for any info!


If you have vod working with the device’s Flash plugin you should be able to do live. Are you testing the live stream in Flash plugin in a browser? Test with Wowza example player: LiveVideoStreaming.


We think we know what might be cause of the issue. We added support for ID3 data tracks in Apple HLS streams in Wowza Media Server 3. The Samsung TV is probably not able to handle these. In the next few days we will add a property to turn off data tracks that should address this issue. We will report back on this thread with a patch and instructions.


Download and install this patch:

Follow instructions here:

Turn off processing of data events in Apple HLS streams (cupertino)

Please do let me know if this solves the problem.


Thanks for the kind words. Happy to know this works.


No need to post duplicates

But I don’t know. Does the device have Flash player? If so, you can do RTMP. Most STB’s use RTSP. Roku uses Cupertino (HLS).


Encoding parameters are probably okay. H.264 video + AAC audio is what Roku requires. Roku has a minimum bitrate for streams of 250kbs, maybe there is a minimum with Samsung internet tv.

A quick search here didn’t come up with anything re hls streaming to Samsung. Maybe Anton has a direct link.


Take a look at this Property setting:


The other thing that has changed is reporting of codec and resolution data in the playlist. You can turn it off with these Property settings set to “false”:


cupertinoChunkDurationTarget can be added to HTTPStreamer Properties list in Application.xml for vod.


You have to know what the key frame frequency of the video to know what you can do with cupertinoTargetChunkDuration following that guide. Use ffmpeg to get info

ffmpeg -i yourfile.mp4

Look for a line like this:

24 fps, 24 tbr, 24 tbn, 48 tbc

tbc/fps = key frame frequency

In the example, key frame frequency is 2 seconds (2000 milliseconds)


Is here any info in the logs about this file when you play it?

What was the rest of the info from ffmpeg?

Does Wowza sample.mp4 work in that same application?

Have you seen these encoding suggestions?


I don’t think you have it set right. It is in conf/[app-name]/Application.xml /HTTPSTreamers /Properties



Sorry, try “false” to get what you want.


Try adding the Property settings in this article, but set them to “false” (the article has them set to “true”)


I’m not sure. Your stream does work in my IPhone 3gs/iOS 5.0.1.


Hi Zoovision,

Once I had it running, a live rtmp stream on a Samsung connected TV. But after a restart of the TV, it has never worked again although I used the same app. The Internet@TV platform seems to be very buggy.


Nothing at that moment, so far I remember. But the flash RTMP streaming seems to be quite instable on the Internet@TV platform.

Buth I have build now a Samsung app based on HLS, that works good on my BDP-6900 from Samsung, but not on my Internet@TV enabled Samsung LED TV.

I don’t know why yet.

Check die Samsung example app on

Yes, it does support HLS. Please check the examples on the Samsung forum.

I suppose that problem may be with cupertinoRelativePlaylistPlaylists.

even setting it to false does not make chunk URLs to start with http://.

can Wowza fix this?

or introduce some property that will change this, so urls will be full like: