Wowza Community

Streaming Problem

http://localhost:1935/

Display this message

Wowza Media Server 3 Developer Edition (Expires: ago 19, 2012) 3.0.5 build1220

http://[wowza-ip-address]:1935> I put this one > http://127.0.0.1:1935/

Display this message

Wowza Media Server 3 Developer Edition (Expires: ago 19, 2012) 3.0.5 build1220

with Flash Encoder configurate as rtmp://127.0.0.1/live and streamer = livestream

Connection via http://localhost:1935 and with external flash player in my personal web in my computer are works fine,

but any external computer not work. (server not found: rtmp://127.0.0.1/live )

???

If the encoder is running on a different machine than the server running Wowza Media Server then you cannot use localhost to address the Wowza Media Server. You must instead use the Wowza Media Server external or NAT IP address. Also, be sure that TCP port 1935 is open on the machine running Wowza Media Server. You can test connectivity to the server from the machine running the encoding software by opening a web browser and entering the address:

http://[wowza-ip-address]:1935

Where [wowza-ip-address] is the external or NAT Ip address of the server running Wowza Media Server. Once you get this working then use this same address in your rtmp URL.

Charlie

I did try your server and VOD works. So the server is up and running. I tried the following:

Server: rtmp://mediacp2.comcities.com/vod
Stream: mp4:sample.mp4

Charlie

If you are on Windows you can get Ip address of a server by opening a command prompt and entering the command:

ipconfig

Charlie

Great. Happy to help.

Charlie

This site will tell you:

http://dnsstuff.com/dnsreport/

Look at top where it says “Your IP Address: …”

Richard

The server is running at that IP, port 1935 is open, but there does not appear to be an application named “live”.

Take a look at this tutorial:

https://www.wowza.com/docs/how-to-set-up-live-streaming-using-an-rtmp-based-encoder

In steps 1, 2 and 3 you create and configure an application, named “live”

Then make the FMS URL:

rtmp://mediacp2.comcities.com:1935/live

Richard

Hi

The [Wowza-IP] needs to be the IP of the server not “127.0.0.1:1935” this IP is local to the computer you are using.

See Charlie’s instructions,

If the encoder is running on a different machine than the server running Wowza Media Server then you cannot use localhost to address the Wowza Media Server. You must instead use the Wowza Media Server external or NAT IP address. Also, be sure that TCP port 1935 is open on the machine running Wowza Media Server. You can test connectivity to the server from the machine running the encoding software by opening a web browser and entering the address:

http://[wowza-ip-address]:1935

Where [wowza-ip-address] is the external or NAT Ip address of the server running Wowza Media Server. Once you get this working then use this same address in your rtmp URL.

Charlie

Jason

Thank you for your reply.

this is my web site player configu.

this is wowsa server when activated.

VHost.xml

-

-

-

-

4

*

- <!-- Separate multiple ports with commas

–>

- <!-- 80: HTTP, RTMPT

–>

- <!-- 554: RTSP

–>

1935

-

true

- <!-- suggested settings for video on demand applications

–>

24000

65000

- <!–

suggest settings for low latency chat and video recording applications

16000

16000

–>

true

- <!-- 0

–>

- <!-- false

–>

- <!-- -1

–>

- <!-- false

–>

100

cupertinostreaming,smoothstreaming,sanjosestreaming,dvrchunkstreaming

-

-

com.wowza.wms.http.HTTPCrossdomain

*crossdomain.xml

none

-

com.wowza.wms.http.HTTPClientAccessPolicy

*clientaccesspolicy.xml

none

What is the probelem that not work with extenal web page?

Thanx be patient

let me try. thanx

Thank you

The port is working correctly. because We streaming with this server rtmp://mediacp2.comcities.com:1935 . we are streaming fine.

I found some Ip addresses but, I can not find a Wowsa IP Address. yet

Flash Encoder erro PROBLEM WITH PRIMARY SERVER.

:frowning:

Yes, I created step 3 also,.Edit the newly copied Application.xml file and make the following changes a.Set the Streams/StreamType property to: live

FMS URL: rtmp://[???wowza-address???]:1935/live

sream : livestream

The problem is, [wowza-address] Where is the IP address or domain name of the server running Wowza Server.

Where can I pic that?

Dear charlie, You are Great!

now my stream work excellent.

:cool:

thanks