Wowza Community

Subscription to ProductCode 8ED157F9 required

I have almost created an application to fire up a wowza media server 3 on amazon ec2 instance on demand but I keep getting this error: “Subscription to ProductCode 8ED157F9 required.” I have a subscription and I have other wowza ec2 servers running I have tried several ami’s. I have started them manually and do not receive this error. I am using the devpay ami’s for us-west-1a m1.small and have tried other zones and ami’s is what Im trying to do possible?


It might take a short while for the subscription to be activated, or there is a billing problem with your AWS account, or maybe you are using another account than the one you subscribed with.


Yes, that is very possibly the problem: changing the email address associated with your account. They are the ones to work with on this.


This is probably a problem with your billing info with AWS, and probably due to you changing that info. We have no insight into AWS systems, you have to contact them directly


If the problem persists and you have already signed up for the subscription, it has always been a billing or account problem in that case.


Jack, Tony, and Ahmed - were you by any chance trying to launch M1.Medium instances? If so, and you had successfully launched Wowza AMIs previously, was that different than the instance size you’d used before?


I have had the subscription for months so thats not it. Im current on billing. I am using the access keys from the account that I have the subscription running on. I did recently update my email address with amazon that couldnt be the issue could it? I have contacted amazon as well.

Thanks for your quick response

Hi, I have the similar problem. I haven’t changed my email address or billing address. I haven’t used it for last 2 months but I was billed £5 for the license which is fine. But now when I am trying to launch ami-41b6b335 i get the same error. But I do have the devpay wowza subscription. Any idea?

I’m also having the same problem. AWS shows me subscribed for Wowza Devkey (when I try to sign up for it again it says I’m already subscribed). But I keep getting the ProductCode 8ED157F9 error message when trying to launch an EC2 wowza instance. Any suggestions?