Wowza Community

Teradek Prism to Wowza – Audio but no video

We recently acquired the Teradek Prism encoder, and when streaming to Wowza we get audio but no video.

When streaming to the same Wowza instance with a Teradek Cube, we get video + audio as expected.

We’ve tried this on 4.8.13 and 4.8.20, with the same result.

Some of the errors we’re seeing are

2022-09-26      11:21:54        CDT     comment server  WARN    200     - 
TranscoderWorkerVideoDecoder.frameDimensionsValid[_defaultVHost_:remote/_definst_/stream6: decodeIterations:0]: 
videoDecoderDecodeDisplayWidth failed [0:32:8192]: Encodes will not be playable -       -       -       1.0086778356E7


 ERROR   server  comment 2022-09-26      15:25:10        -       -       -       -       -       1.0101373719E7  - 
> -       -       -       -       -       -       -       H264Utils.decodeAVCC : java.lang.Exception: Expected to parse 
> SPS of length 42 bytes, but 8 bits remained|at|at 

Hmmm… that’s interesting since we do support the Teradek Prism. Can you tell me the following:

  1. What is the protocol you are using? RTMP? SRT? MPEG?
  2. Are you sending a 4K stream?
  3. What version of Java are you using?

I will look for your reply.

Something within the source settings Wowza is not liking. e.g. H.264 profile range compared to frame size and resolution. Please open a support ticket with a screenshot of the Teradek settings (resolution, H.264 profile, video/audio bitrates), stream name in question, if you are transcoding, WSE conf/logs/transcode template/ for support to review).

  • RTMP
  • Not 4K. I’ve tried 720 + 1080
  • Java Version 9.0.4 Java VM Version 9.0.4+11

These are the full Teradek specs.

And I have submitted a ticket.

try to add the below property in Application.xml, Streams/Properties section:


i think this is the problem, but I see you have a ticket in and it will get assigned today: You need to have a minimum of Java 11 for Engine 4.8.20. I know you mentioned issues in a different version though so tech support will troubleshoot this accurately.

Java support: Wowza Streaming Engine 4.8.20 is built on Java 11 ( OpenJDK Java SE JRE 11.0.2 ), but can be used with Java versions 11 - 12. For more information, see Manually install and troubleshoot Java on Wowza Streaming Engine.

Unfortunately, this error can be thrown for more than one reason which makes it difficult to diagnose in the forums.

If updating your Java doesn’t work Bryce, I see that tech support has sent you some troubleshooting tips in your ticket to see if it’s a problem with your encoder itself connecting to Wowza although we do support that model.

After talking to Teradek and rolling back the firmware a few versions, this seems to be resolved.

So I believe they’re working on a fix, although still not sure what the root cause of the issue is.

I saw that in the ticket, so glad you brought this to our attention and hope it gets resolved to go back to the newer version of the firmware.