Wowza Community

Trouble delivering FLV content from WOWZA to JWPlayer.


I am using WMS to deliver on demand content to JWPlayer.

When i use the following streamer/id: rtmp://localhost:1935/vod/mp4:sample.mp4, everything works fine. I look at wowza logs and the mp4 file is found and hence delivered.

See the logs:

2014-03-24 17:04:03 IST pause stream INFO 200 sample.mp4 - defaultVHost vod definst 57.006 [any] 1935 rtmp://localhost:1935/vod/ rtmp http://localhost/Player/jwplayer/jwplayer.flash.swf WIN 12,0,0,77 1028367951 3665 4025199 1 61667 0 4021299 sample.mp4 - C:\Program Files (x86)\Wowza Media Systems\Wowza Streaming Engine 4.0.0\applications\vod\content\sample.mp4 mp4 39115156 596.458 rtmp://localhost:1935/vod//sample.mp4 rtmp://localhost:1935/vod//sample.mp4 - rtmp://localhost:1935/vod/ -

But when I use rtmp://localhost:1935/vod/flv:sample1.flv, The player fails to load video and says “ID not found on server.”

See the logs:

2014-03-24 17:05:52 IST comment server WARN 200 -[vod/definst]: Not found: C:/Program Files (x86)/Wowza Media Systems/Wowza Streaming Engine 4.0.0/applications/vod/content/sample1.: C:\Program Files (x86)\Wowza Media Systems\Wowza Streaming Engine 4.0.0\applications\vod\content\sample1 (The system cannot find the file specified)|at Method)|at|at|at|at| - - - 209.744 - - - - - - - - - - - - - - - - - - - - - - - - -

As one can notice the .flv extension is removed in this case. Why is this so?

Please help as flv files are being played from the VLC player or macromedia flash player (using the above streamer/id).



Hi there, are you getting any other errors accompanying this error?

A couple causes for this error are if Streams/StreamType isn’t set correctly in Application.xml.

Also, could be a typo somewhere.

Can you explain your set up? And if there are other errors please post them.



The vod playback issue with jw player is a known issue and we have been in contact with the engineers at JW Player to modify their player to fix it.

In your live streams, please make sure you are prefixing the file names that are being inserted into the live streams. If you are still having issues the please post a sample of your code that you are using to create the streams.

Also prefix the name of the live stream when you create it.


Stream flvStream = Stream.createInstance(vhost, "live", "flv:flvStream");"flv:sample1.flv, 0, -1, true);
. . .
Stream mp4Stream = Stream.createInstance(vhost, "live", "mp4:mp4Stream");"mp4:sample.mp4", 0, -1, true);
. . .

Note: live sources inserted into the streams should not be prefixed. The reason is that the live stream handler doesn’t handle the prefixes.


So I tested this with Wowza 4.0.1 build number 10615 and received the same error as you described.

Wowza 4.x has changed the default stream prefix from flv to mp4, so to fix your issue you can change the default back to flv.

In the UI edit Server/Basic and change Default Stream Prefix to flv, restart the server and it should work for you.


Thanks Salvadore.

I did the changes and it worked fine for vod application.

The same didn’t work for live application though. On server startup I wrote a listener to start a .mp4 video and .flv video. (similar to

The streamers now become rtmp://localhost:1935/live/mp4Stream and rtmp://localhost:1935/live/flvStream.

The mp4Stream works but flvStream does not.

Hi Roger,

Thanks. My live streams also started to work. I didn’t prefix the stream names earlier. But I couldn’t understand that, if missing prefixes was the problem why did the mp4Stream start in the first place.

As for the VOD playback issue should I go for what Salvadore suggests or should I wait till the issue fix is dissolved and a new jw player build is released?