Wowza Community

Troubles with gstreamer & wowza server


we at Vienna University try to stream a testvideo via gstreamer to our Wowza Media Server by using this command:

gst-launch-0.10 -v videotestsrc ! “video/x-raw-yuv, format=(fourcc)I420, width=(int)640, height=(int)480, framerate=(fraction)15/1” ! queue ! x264enc bitrate=500 cabac=false pass=qual quantizer=27 subme=4 threads=0 bframes=0 dct8x8=false ! queue ! rtph264pay ! queue ! udpsink host= port=10004

The rtp packets are recieved just fine, so firewall settings are not the reason for our problem. We try to view the stream by JW Player (Longtail setup wizard: rtmp stream, file: udp://, streamer: rtmp:// However, the flash player remains black and doesn’t show our stream.

For your information, we have this cap for our videostream:

caps = application/x-rtp, media=(string)video, clock-rate=(int)90000, encoding-name=(string)H264, sprop-parameter-sets=(string)“Z0LAFrkQFAe2AiAAAAMAIAAAAwPB4sXU\,aM4XIA\=\=”, payload=(int)96, ssrc=(guint)2438042987, clock-base=(guint)2413324687, seqnum-base=(guint)449100

our SDP-file looks like this:


o=- 1208520720 2590316916 IN IP4



c=IN IP4

t=0 0

m=video 10004 RTP/AVP 96

a=rtpmap:96 H264/90000

a=fmtp:96 media=video; clock-rate=90000; encoding-name=H264; profile-level-id=4d4015; sprop-parameter-sets=Z0LAFrkQFAe2AiAAAAMAIAAAAwPB4sXU,aM4XIA==; ssrc=2438042987; clock-base=2413324687; seqnum-base=449100

Do you have any ideas where our problem might be? Is our gstreamer pipeline or sdp-file wrong (it shoul be okay according to Using gstreamer-0.10 with Wowza), or do we need further settings for our wowza media server? Any advice is welcome :slight_smile:

Thank you for your help in advance,


PS: our log file might help you finding a solution:

This value looks wrong:


Try taking it out. We can re-calculate this part from the sprop-parameter-sets. What is in the sprop-parameter-sets looks correct.


Are you running the latest, latest version of GStreamer. We have seen problems with older versions of their software. I would be sure you are very up to date with their software.

I see the most recent version is:

GStreamer Core 0.10.35, Base Plugins 0.10.35, Good Plugins 0.10.30 stable release


We have had problems in the past with gstreamer and Wowza. That is why we have not supplied specific instructions. We do not have very much experience with gstreamer to really help much. I did have it working 2-3 years ago but only with a very basic setup. I might work with the gstreamer team to see if they have any suggestions.


Hi gergely,

I’d like to help you troubleshoot this while Charlie is out. What changed such that the stream from Windows (VLC) to Wowza started working? Is there now any different information in the logs now or any other detail you can share?


hi charlie,

thanks for your fast reply. we have tried taking the profile-level-id out of the sdp-file, however without any effect. the stream is still black in the jw player …

Do you need maybe further logs, files etc. for testing? We could provide them to you if you need …

Thanxs for your help …


Hi charlie,

I’ve just checked our gstreamer version … we are on the latest versions. In the meantime we did further testing and could achive to stream a Webcam signal from Windows (VLC) to our wowza channel, however failed to stream from our Ubuntu client (also with VLC) to the same channel. Does this info give you some hint for “debugging” ? :slight_smile:


Thanxs for for your help … well, by trying Windows (VLC) we just wanted to test if streaming from a different plattform works or not. At Windows (VLC) we just stream a webcam to the same wowza channel to see whether it can recieve the signal. However, the combination gstreamer & wowza channel still does not work … regardless of the gstreamer udpsink setting … we tried the following:

! video/x-raw-yuv, width=1024, height=768 ! ffmpegcolorspace ! ffenc_mpeg4 ! rtpmp4vpay ! udpsink host= port=10004

and also

! videoscale ! video/x-raw-yuv, width=1024, height=768 ! x264enc bitrate=500 ! rtph264pay ! udpsink host= port=10004 sync=true

Do you have any ideas?