Wowza Community

ULL stream create REST API call returns 404

I am on a 30-day trial account for Wowza Streaming Cloud.

I’m trying to create a ULL stream through the REST API as documented here:

This is what my call looks like

curl -X POST \
-H "wsc-api-key: <MY_API_KEY>" \
-H "wsc-access-key: <MY_ACCESS_KEY>" \
-H "Content-Type: application/json" \
-d '{"stream_target_ull": {"name": "My Ultra Low Latency Push Target", "source_delivery_method": "push", "enable_hls": true}}' \

I get a 404 error as response. I tried without access key and with timestamp+signature instead. Same result.

The corresponding GET request works:

curl -X "GET" \
-H "wsc-api-key: <MY_API_KEY>" \
-H "wsc-access-key: <MY_ACCESS_KEY>" \
-H "Content-Type: application/json" \

This returns a list of my existing ULL streams as expected.

What’s wrong with the POST request? I seem to be using it exactly as it is documented.

Looking at this now - I can successfully execute the POST in Advanced REST Client, but I also get the 404 you do in curl.

Your URL is referencing the API version incorrectly - you have 1.3 and you need v1.3