Wowza Community

Unable to restream from multiple sources, samples work

Hi there,

I have a new Wowza Streaming Engine installation that I’m trying to get set up to restream an Axis camera - the P5515. So far, here are the symptoms:

First, Wowza seems unable to connect to the camera. I see regular errors in the logs that say the following:

  1. “LiveMediaStreamReceiver.doWatchdog: streamTimeout[axis-media/definst/media.amp]: Resetting connection: rtsp://{my_server}:{my_port}/axis-media/definst/media.amp” (where {my_server} and {my_port} are the valid IP/port combindation for the camera
  2. RTPSessionDescriptionDataProviderBasic.getStreamInfo: RTSP/RTP re-streaming timeout.
  3. RTPSessionDescriptionDataProviderBasicRTSPWorker.processResponse: CSeq less than zero

Depending on exactly how I connect to my configured stream, I either get “Waiting for Stream” if I connect with MediaCaster Type “rtp” or I get “Active” if I connect with MediaCaster Type “liverepeat” - As far as I’ve been able to tell, that makes no difference in the logs, and it definitely does not make any difference in ability to connect to Wowza’s stream either from the Test Players or from VLC (neither works).

The correct URL to my stream is rtsp://{my_server}:{my_port}/axis-media/media.amp and I’ve verified this works on the machine Wowza is running from via VLC. I’ve also tried streams from other source (restreaming from VLC on another machine via same network) with similar symptoms - I can play the stream from the Wowza server in VLC, but cannot restream it in Wowza, with the same error messages. There could be firewall issues at play with the subnet for the main camera, but that doesn’t easily explain why streaming it from VLC works, or why the stream from another computer not behind that firewall didn’t work in Wowza, but did in VLC, and I believe my firewall settings are good (including opening them up pretty wide for some testing).

When I try to play the sample.mp4 from the vod application, either in the browser player, or via VLC, I am able to get that to work as expected.

I’ve set up this application multiple times, first by just using the setup configuration from selecting Axis camera under “Sources (Live)” and configuring from there, and then again by manually configuring the whole application. I’ve set the server up to stream on both, but neither port works. In fact, trying to connect to the device by IP from the device (in VLC) results in an immediate rejection, but trying to use localhost or makes it wait 15 seconds or so before failing - assuming it’s connecting to Wowza, then failing later, but unsure.

I have configured the application to not require authentication, and the camera is configured to allow viewing without authentication, which can be confirmed in VLC. I have followed setup guides and looked at forum posts about these errors and with similar descriptions, with the most notable guide being this one (, including setting many of the advanced troubleshooting options.

I’m at a bit of a loss for how to proceed here - I’m happy to provide any additional information on my setup and troubleshooting. Thanks for any help in advance.

I forgot to add that this is Wowza Streaming Engine 4.7.1 on Windows 10. Incoming stream is h264 1920x1080, 30FPS with half duplex AAC audio