Wowza Community

Update from Wowza 4.7.5 to 4.8.5 Java Issue

Hi, I am trying to update to Wowza 4.8.5 from version 4.7.5 for Windows 7.

I downloaded, extracted OpenJDK Java SE JRE 9.0.4 first and then copied and pasted the Windows-x64 folder to the Wowza 4.7.5 Jre folder. The problem I am encountering after following the steps -

C:\Program Files (x86)\Wowza Media Systems\Wowza Streaming Engine 4.7.5\updates\WowzaStreamingEngine-Update-4.8.5\windows> update.bat

Error msg: Did not find valid ‘WMSJAVA_HOME’ VALUE… and also Java version unknown.

How can i pass this last Java unknown issue. Thanks!


It sounds like you did as the instructions say to do which is:

Copy the contents of the directory with the name matching the host OS, and past them into the WSE [install]/jre directory.

Something you can try and you shouldn’t HAVE to to do this, but it worked for me in testing is delete what you pasted in already as far as the main Windows x-64 folder. Go back to the initial step of copying the folder, but this time actually click and open the folder for Windows x-64 and copy and paste each individual folder inside to your jre

Restart the server of course after all these all these steps and please let me know if that worked. Thanks.

Hi Rose thanks! I followed ur instruction and renamed the previous Wowza 4.7.5/Jre folder and created a new Jre folder and moved the folders inside the Windows x-64 OS to it. I followed the Wowza instruction and typed ‘update.bat’ and my wowza 4.7.5 was updated to wowza 4.8.5 successfully. I checked the About section on Wowza streaming Engine and it shows the updated Wowza version 4.8.5 and the Java Version 9.0.4. I will try to test the wowza server and will update you if I encounter any errors. Thanks so much for everything in the mean time!


This is good to hear. Sorry you had to do it that way, I’ll bring it to the attention of the engine team.

Nothing I do will get this update to install. Doesn’t matter where I extract it. Doesn’t matter if I set WMSJAVA_HOME variable as system or user. It just says I don’t have a compatible version of Java.