Wowza Community

Visual Artifacts when using NVEnc

hi there … I’ve a couple of questions. I’m having artifacts when transcoding with NVENC

I found this to be a bug as following article.

Even though, the workaround doesn’t work for me. Is there any update about it?

On different topic, I’d like to know how to set up following things

a) I’d like to set transcoding to be CBR, instead of VBR … how can I set that either for software transcoding or hardware accelerated

b) I did some test passing stream through Main Concept and through NVEnc card. With same values on the template (except the mentioned), I’ve noticed that level of encoding is different. Is there a way to set that up?

For instance, with same values, Main Concept uses L3.1 and Cuda card uses L2.1


Hi Tavius,

Please can you open a ticket by sending an email to

When opening a ticket please include a description of the issue, a link to this thread for reference and a zipped copy of the following directories:







I did reply with an update to your support ticket.

For the greater audience, the issue was the placement of the Parameter block

provided in this article

and needed to be placed within a Parameters container.