Wowza Community

Vlc RTP Live

You need to be sure you open the right kind of ports. For RTP the ports are UDP. So be sure you are opening UDP ports:

ec2-authorize default -P udp -p 10000-10003

QuickTime Broadcaster can either use RTSP/RTP (Automatic Unicast Announce) or native RTP with an SDP file (Manual Unicast). So if you want to simulate what VLC is doing you want manual unicast. You can export an SDP file from the File->Export menu.


Very strange. Not sure where to go from here. I just tried this again today with an EC2 image that I have up and running and it is working fine. If you send me the ip address of your instance I can try to send a stream to it and play it back to see if I can get it to work. Send it to I assume you are running the default startup package?


I am not sure what you mean by this:

do you know of any flash-java based that allows to stream-transcode


I would copy the sdp file before starting in StreamManager.

Try it in LiveVideoStreaming example player with

Server: rtmp://...*:1935/rtplive

Stream: vlc.sdp

Is there anything interesting in the log files?


If you don’t change any vlc settings you can use the same sdp file.


The only way I know to test is put it all together and see if it works. This is the Quicktime Broadcaster guide:


Actually, we’re not promoting consulting, Wowza does software. We would like to see this start working for you. The usual problem between two computers is ports and firewalls.


On EC2, it is the Security Group. You have to add ports to the security group. The Wowza EC2 guide has instructions.


That looks okay.

I would focus on EC2 security groups, getting that right.

You need to add UDP ports in some case,TCP in others. The CIDR values is always “” <-- check that

Are you using the Firefox ElasticFox plugin?


Look at this post:


You won’t need all these, and I don’t remember why I have half of them, but for reference this my default security group:


You need to add:

UPD 6970 - 9999


Won’t work because Flash plugin does not encode to h.264 baseline 3, which is required by IPhone.


You can use enocder that does rtmp or rtp/rtsp push.


How can we test two things for our streaming?

  1. Cam on mac with broadcaster to a diff server, to confirm stream can be received?

  2. A diff stream to our EC2 server

Therefore narrowing down where the pipe is clogged?

Guys we have indeed followed all of this and are obviously missing something. We have asked for assistance in many different ways.

Now it feels like we are going to be led around in circles until we pay the $300hr consulting rate Elan quoted us.

We truly want to say WOWZA but aren’t feeling the love.

What other things can we post to help diagnose the issue?

Charlie what are all of the other files we can send to help diagnose this?


Well that did not worked,

here is my steps

on my pc run this command

vlc -vvv -I rc dshow:// :dshow-vdev="CyberLink Web Camera Filter" :dshow-adev="External Mic (IDT High Definiti" :dshow-size="640x480" --sout "#transcode{venc=x264{keyint=60,profile=baseline,level=3.0,nocabac,qpmax=36,qpmin=10,me=hex,merange=24,subme=9,qcomp=0.6},vcodec=x264,vb=500,scale=1,acodec=mp4a,ab=96,channels=2,samplerate=48000}:rtp{dst=***.***.**.***,port-video=10000,port-audio=10002,sdp= file://d:/vlc.sdp}"

then go to stream manager


enable the rtp live stream

copy the vlc.sdp file generated in my pc on the server (content folder)

and then try to run on iphone


is there any step that im missing-skipping?

Thanks for your help

question , does the sdp changes between runs? i just did the exact instructions

also extracting useful data in the logs (i see a lot of warns) as there are also some from the streaming (Comments) that we are doing to our site

here are something interesting

WARN    server  comment 2010-01-12      19:03:28        -       -       -       -       -       631943.319      -       -       -       -       -       -       -       HTTPStreamerAdapterCupertinoStreaming.getAppInstance: Stream not found [rtplive/vlc.sdp/playlist.m3u8]: vlc.sdp
WARN    server  comment 2010-01-12      19:05:44        -       -       -       -       -       632079.604      -       -       -       -       -       -       -       RTPSessionDescriptionDataProviderBasic.getStreamInfo: SDP file missing: /usr/local/WowzaMediaServer/content/ 
        at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerDynamicMBean(
        at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerObject(
        at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(
        at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(
        at org.apache.commons.modeler.Registry.registerComponent(Unknown Source)
        at org.apache.commons.modeler.Registry.registerComponent(Unknown Source)
        at com.wowza.wms.admin.AdminMediaCasterListener.onMediaCasterCreate(Unknown Source)
        at com.wowza.wms.application.ApplicationInstance.notifyMediaCasterCreate(Unknown Source)
        at com.wowza.wms.mediacaster.MediaCasterStreamItem.checkMediaCaster(Unknown Source)
        at com.wowza.wms.mediacaster.MediaCasterStreamItem.registerPlayer(Unknown Source)
        at com.wowza.wms.mediacaster.MediaCasterStreamMap.registerPlayer(Unknown Source)
        at Source)
        at com.wowza.wms.module.ModuleCore.internalPlay(Unknown Source)
        at Source)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(

the server does not see the vlc file on the server?

is there any special user-permission that this file needs?