Wowza Community

WebRTC demo page and Firefox


I couldn’t make Wowza WebRTC GitHub example code working on Firefox (v 82.0.3), and found out that the demo page doesn’t work either on Firefox but works well on Chrome (Chromium 86.0.4240.198).

The demo page finishes with an error in the console: “WebRTC: ICE failed, add a STUN server and see about:webrtc for more details”.

Any idea how to fix this?


*edit: I just found out that the WebRTC Playback Page (the link found in the “Overview” tab of my Live Stream) doesn’t work either on Firefox.

we have the same issue.

Firefox only uses UDP where other browsers support both TCP and UDP

Wowza Streaming Cloud workflows for WebRTC only support TCP. Not UDP. It has to do with firewalls in a Cloud deploy that aren’t an issue in Engine. So, this eliminates Cloud and Firefox since Firefox only uses UDP.

Because Firefox only supports UDP and you must also use UDP, then in Wowza Streaming Engine, you will need to enable UDP as the ice candidate to make WebRTC work in Firefox.

In summary:

For WebRTC with Wowza IF you’re using Firefox:

Cloud: UDP only so no Firefox
Engine: Yes to Firefox, if you have UDP enabled as Ice Candidate.

Ok, thanks for the reply.
I’m using Wowza Cloud, so I guess I have to forbid my users to use Firefox.

Is there any other mainstream browsers that cannot be used with Wowza WebRTC + Wowza Cloud?

thanks for the quick reply!

My pleasure. Hope it helped.

I had both UDP and TCP enabled as ICE candidates from the beginning but still unable to play WebRTC stream in Firefox. Could there be any other reasons why stream won’t play?

Same here. Both UDP and TCP enabled (UDP as default). Still doesn’t work:
WebRTC: ICE failed, add a STUN server and see about:webrtc for more details

Issues have been open for more that 2 years about this.

Only works if UDP is the only ICE candidate option.

Doesn’t work in Firefox at all for me, even if I remove all options but UDP from ICE Candidate Setup.

Sorry to hear that @Dmitry_Smith . We’d need a support ticket to review your configuration and debug. Nothing has changed as far as the the UDP requirement for FireFox so we’d need to further investigate.

Sorry for inconvenience, that was a firewall related issue.