Wowza Community

WebRTC inside LiveHTTPOrigin-Application


I like to ingest a stream via WebRTC and have it packaged to HLS for delivery via CDN. I tested this with my developer license inside a “live” application (cuz developer license does not support http live origin) just fine.
Now I wanted to setup our production server and struggled to find the “WebRTC” menu point inside a “live http origin” application. Am I missing a configuration which enabled this menu point? I can see it for the default “live” application.


1 Like

A warm welcome to our forums @Lars_Kreisz1. :hugs: This is a good question and I’m not sure we highlight this in our docs. Let me chat with our Engine team and I’ll be back shortly.

1 Like

We do not have a configuration for this in Engine Manager, but will need to be done in the. .xml

XML configuration
  1. Use a text editor to open the [install-dir]/conf/[application]/Application.xml file for your HTTP origin application and add the following property to the <HTTPStreamer> / <Properties> container. Be sure to add the property to the correct <Properties> container in Application.xml as there are several such containers in the file.

    <Property> <Name>httpOriginMode</Name> <Value>on</Value> <Type>String</Type> </Property>

Apple HLS cache-control properties

These properties are required for delivery using the Apple HLS protocol.

  1. Restart Wowza Streaming Engine to apply the changes.

Please use this doc as a reference and be sure that you have SSL cert configured of course since https is required for WebRTC.

Our engineers will gladly walk you through this in a support ticket.

1 Like

Hey Rose,

as I understood you told me to customize the “live” application (where webrtc options are available via Manager UI) via XML to activate HTTP Origin functionality. I’m sure this works but I did the other way and did the WebRTC changes on my “live http origin” application via XML and it works fine now.

Thank you very much!
Best Regards, Lars.

1 Like

Oh that’s fantastic to hear it works now for you. Really appreciate you letting me know that. :grinning: