Wowza Community

webRTC jerky and/or inverted with transcoder


I tested a webRTC application (with trial licence). An incoming H.264 RTMP (1080p@30fps 6000kbit) can be playback with webRTC in PC Chrome without any problem, that working very-very fine.

But if I set transcoding for that, happend:

to H.264 (540p@30fps 1200kbit) -> jerky vibration in stream (only with webRTC, VLC can be play right!!!)
to VP8 -> inverted color (only the stream, the wowza logo overlay is right) and low qality squares stream
to VP9 -> better quality, also inverted colors, sometime 1-1 sec disintegration to squares

I do something wrong, or is something limitation in trial licence?
(only 1 incoming, only 1 transcoded stream and 12 vcpu less than 20-50% load, 16Gbyte RAM…)


We suggest you only use VP9 for WebRTC playback, but as far as why you are seeing issues with the colors, we’ll need a support ticket to fully review your configuration and test, we cannot troubleshoot in the forums. It shouldn’t be related to the trial if you have SSL configured correctly.

I also noticed this problem, it only occurs when the transcoder has the baseline profile set.

Thanks, but unfortunately, doesn’t help. If I used the main or high profile the player ( cannot be play the stream. (It is a strange thing, generally we tested with a H.264 high profile stream without transcoder and worked well in chrome)

When I decreased to 720p the incoming stream and use high profile the H.264 worked (the VP9 was same bad colors).