Wowza Community

Webrtc publish/play not working from MS Edge browser


We have a WSE (4.7.0) installed, and we followed the instructions from this page to enable WebRTC support. We mostly used the values from this documentation, the only difference is that we have a different name for our application and also we configured our our own keys and ip addresses.

Publishing streams and playing them back works well in both Chrome and Firefox, but we couldn’t make it work in Edge.

We are using the latest publisher and player from here.

When I try to play an already exitsting stream in Edge, the only error I get is regarding to the websocket connection which is apparently terminated abnormally. As far as I can tell the connection is only closed when it should be, so I don’t think that causes the issue. Nothing else happens, the video object looks like it is playing something, but there is nothing there, no video, no sound, also there are no error events fired from the video.

When I try to publish from Edge I get an invalidAccessError (webrtc.js, line 165, peerConnection.addStream)

I downloaded this package and modified the code, I added adapter.js to see maybe it helps, but that resulted in a bunch of different errors.

Am I doing something wrong, or is Edge not supported?

Getting this same errors in Edge too. Chrome, FF, Opera are working.

Hello @Norbert Süle

Microsoft Edge is currently not supported with WebRTC Preview. We do have a backlog to look into this request, although there’s no timetable or guarantees set yet.


Jason T

Is there any news on this?

Hello @Stijn van der Laan

Edge is currently still not supported with WebRTC Preview and no timetables set yet.

Please keep an eye on this update page link for updates on this.



hi guys. any news or ETA on this ?

Is there still no support for WebRtc in the Edge browser? Edge is the native browser in Windows 10 and 99.9% of our customers use it! We really need this support soon or we are going to have to switch to another product like Red 5 that supports WebRtc for Edge.

Agree with Meisho. WebRTC is an absolute must for us. We had to stop using Flash for what should be obvious reasons. However for the default browser of any new Microsoft install to not work with Wowza WebRTC is a complete show stopper.

Can we please have some confidence that WebRTC is becoming a priority for you rather than the constant “not supported, no timetable set yet” responses. We too will have no option but to move away from Wowza (have been a customer for 6 years) if this continues for much longer.

Thank you.

Apparently in the kurento group they said that in order to finalize the ICE session you need to provide an empty candidate, ie Edge’s WebRTC is non-standard. While I get the feeling it (and Safari) are moving forward Chrome and Firefox should be used in preference.

Indeed part of the problem is the client-side WebRTC APIs are moving and things are changing. Things like the handling of mediaStreams vs mediaTracks and the format and parameters of constraints.