Wowza Community

Webrtc streaming issue with Wowza and FFMPEG

I am trying to stream video and audio from a Camera in a browser using Webrtc and Wowza Media Server (4.7.3 version).

The camera stream (h264/aac) is first of all transcoded by using FFMPEG (version N-89681-g2477bfe built with gcc 4.8.5, last available version on ffmpeg website) in VP8/OPUS and then pushed to the Wowza Server. By using the small Wowza webpage I ask for the Wowza stream to be displayed in the browser (Chrome Version 66.0.3336.5 Build officiel canary 32 bits).

FFMPEG used command :

ffmpeg -rtsp_transport tcp -i rtsp://<camera_stream> -vcodec libvpx -vb 600000 -crf 10 -qmin 0 -qmax 50 -acodec libopus -ab 32000 -ar 48000 -ac 2 -f rtsp rtsp://<IP_Address_Wowza>:<port_no_ssl>/<application_name>/test

When I click on Play stream I have a very bad quality video and audio (jerky video and very bad audio).

If I use this FFMPEG command:

ffmpeg -rtsp_transport tcp -i rtsp://<camera_stream> -vcodec libvpx -vb 600000 -crf 10 -qmin 0 -qmax 50 -acodec copy -f rtsp rtsp://<IP_Address_Wowza>:<port_no_ssl>/<application_name>/test

I will have a good video (flowing, smooth) but no audio (the camera micro is ON).

If libopus is the problem (as this test first shows), I tried libvorbis but with Chrome console I have this error “Failed to set remote offer sdp: Session error code: ERROR_CONTENT”. Weird, cause libvorbis is one of the available codecs for Webrtc.

Is someone experiencing the same issue ? Did someone experience the same issue ?

Thanks in advance.

  1. You probably have no audio because opus must have sample rate of 48000

You should add the flag:

“-ar 48000”

to the output settings

  1. I also experienced the “bad quality video and audio issues”.

I finally solved the issue by adding:

“-quality realtime” to the output settings .

That work well for me, I hope this will help you.