Wowza Community

Windows 2008 R2 Service

I am new to WOWZA and have installed it. If I run the startup.bat the service starts. however, if I try to start it from the service control panel, I get an error 1067 operation failed. Is there something I am missing here? I have it set to use a specific account, and have also tried logona s a service but neither one works. I have JRE7 installed and have my JAVA_HOME env set as well.

Hello haarvik,

Is there more to the Windows error message? Which version of Wowza?

Sounds like something went wrong with your installation. Try uninstalling Wowza, rebooting, and re-installing Wowza.

Another user had a similar error here, which was a typo.

JAVA_HOME is an environment variable. Search for “edit the system environment variables”


Mine is set to C:\Program Files\Java\jdk1.7.0


Start > “edit the system environment variables”


This is set at the top of /bin/WowzaMediaServer-Service.conf:\bin\java.exe


I don’t think there is any other place in Wowza that it might be happening.


You have an extra “bin” folder in your Java path for some reason. Set your JAVA_HOME=C:\Program Files (x86)\Java\JRE6\bin. Or, even better, install JDK1.7.

I found what the issue is, just not sure where to correct it. The wowza log file is saying it can’t find C:\Program Files(x86)\Java\JRE6\bin\bin\java.exe.

My JAVA_HOME is set to C:\Program Files(x86)\Java\JRE6. So where would I fix the path that the service is trying to find which is incorrect?

here is the log error:

–> Wrapper Started as Service

STATUS | wrapper | 2012/05/05 06:51:38 | Launching a JVM…

FATAL | wrapper | 2012/05/05 06:51:38 | Unable to execute Java command. The system cannot find the file specified. (0x2)

FATAL | wrapper | 2012/05/05 06:51:38 | “C:\Program Files (x86)\Java\jre6\bin\bin\java.exe” -Xmx768M -Dcom.wowza.wms.native.base=“win” -Dcom.wowza.wms.runmode=“service” -Dcom.wowza.wms.ConfigURL= -Dorg.tanukisoftware.wrapper.WrapperManager.mbean=true -Dorg.tanukisoftware.wrapper.WrapperManager.mbean.testing=false -Djava.library.path="./" -classpath “./wms-bootstrap.jar;./wrapper.jar” -Dwrapper.key=“d_ms9ZGYMvQClmfp” -Dwrapper.port=32000 -Dwrapper.jvm.port.min=31000 -Dwrapper.jvm.port.max=31999 -Dwrapper.version=“3.2.3” -Dwrapper.native_library=“wrapper” -Dwrapper.service=“TRUE” -Dwrapper.cpu.timeout=“10” -Dwrapper.jvmid=1 org.tanukisoftware.wrapper.WrapperStartStopApp com.wowza.wms.bootstrap.Bootstrap 1 start com.wowza.wms.bootstrap.Bootstrap true 1 stop

FATAL | wrapper | 2012/05/05 06:51:38 | Critical error: wait for JVM process failed

I know that…it is set correctly. If I start wowza from the startup.bat script it works fine. Why is the service startup inserting another \bin\into the JAVA_HOME environment variable?

As I posted initially, mine is set to:

C:\Program Files(x86)\Java\JRE6

The log file says wowza is looking for it in:

C:\Program Files (x86)\Java\jre6\bin

So where do I edit to remove the extra \bin\ ?

I know that! You’re not reading what I am saying!

echo %JAVA_HOME%


C:\Program Files (x86)\Java\jre6

So it is set right. Whatever the service control manager is calling to start wowza THINKS that JAVA_HOME is C:\Program Files (x86)\Java\jre6\bin and NOT C:\Program Files (x86)\Java\jre6! Where is this path set? It is obviously NOT using the environment variables or the extra \bin\ would NOT be in the path!

Yep, and that is what mine has in it. Still doesn’t explain where the extra \bin\ is coming from. It as if that line of code were:\bin\bin\java.exe