Wowza Community

wowza and java8 ?


Wowza works with the new java8 ? with all improvements added, I imagine new wowza version will be launched soon to integrate all these new things ?

thanks for info



I have not heard reports from Engineering or QA on testing with Java 8. I am downloading and will try, which I expect will work. It is unlikely that Wowza will utilize new features of Java 8 for general purposes because there is a business requirement for Wowza Engine to work on Java 1.6.


To follow-up, Wowza had no problems starting and doing basic streaming using jdk1.8.0. It should work for all features and functions.



I am experiencing some problems with Oracle Java 1.8 (I tried both jre 1.8u5 and u20): After I start a stream (for example with the “Test Player”-Feature of the Engine Manager) it will play only for about 10sec. Then it freezes and it is not possible to start another one. Wowza is stuck - the cpu-usage of the wowza java thread goes up to 100% and if I try to restart the Engine it ends with “Killing process (20664) which didn’t stop after 20 seconds”…

This happens on my testserver which is located in a VMware virtual machine. The specs of the VM are: SLES 11 SP3, 2GB Ram/1 core, Wowza 4.0.6 with Dev Licence, Java Max Heap Size 793MB

Everything works fine with IBM Java 1.6.0 and Oracle Java 1.7.0_55. Wowzastreamingengine_error.log reports nothing.

As we have to upgrade our live server to Java 1.8 due to the end of support of Java 1.7 it´s quite important to solve this problem.

Does anybody have an idea about this?



Hi, it seemed as if the problem caused by Oracle Java 8 as my Solr server made some problems as well. I switched to IBM Java which solved my problem - and it is supported by the rpm manager.

Anyway thanks for your thoughts,



If you haven’t already, try updating to the latest release, 4.0.3, see if this issue is fixed.

This is how to apply updates.


Hi Treb, I think we will need to review your /conf and /log folders to better assist in troubleshooting.

Can you please zip these folders up and send them, along with a detail description of the issue you are experiencing to to open a support ticket.

Thank you.


Okay, thanks for the information and the update. Glad to hear you got something working.


Ive found that the Home / Status - Connections and Usage charts do not display when Wowza is using JDK 8 but with 1.7_51 its fine.

Saying that, it appeared to stream fine, and the application monitoring charts were all fine with jdk 8 as well - odd.