Wowza Community

Wowza Engine Rest API PHP

Hello everyone, I’m trying setup this library to manage Wowza engine from my application.
I’ve installed library with composer.

If I run

$server = new Com\Wowza\Server($setup);

$sf = new Com\Wowza\Statistics($setup);
$response = $sf->getServerStatistics($server);

Everyting works fine.

If I run function like StreamTarget in this way:

$sf = new Com\Wowza\StreamTarget($setup, 'live');
$response = $sf->remove('ppsource');

Or like this

$sf = new Com\Wowza\StreamTarget("live");
$response = $sf->getAll();

Or like this

$sf = new Com\Wowza\StreamTarget("live");
$response = $sf->create("myStream","ppsource","rtmp","locahost",null, null,"myStream");

I got this error:
syntax error, unexpected 'public' (T_PUBLIC), expecting ',' or ';' in .../wowza/wse-rest-library-php/src/StreamTarget.php on line 24

To be clear, this is my $setup:

$setup = new Com\Wowza\Entities\Application\Helpers\Settings();

This is my $server (if needed)
$server = new Com\Wowza\Server($setup);

I’m using PHP5.5.

P.s There is a differenze from using “com\wowza…” or “Com\Wowza…”? On tests inside library, I’m finding always lowercase, but for my configuration works only with 1st character capitalized.

Thank you

Are you using the latest version of the REST library for PHP? Because on July 1st, there was a small update that fixed that exact bug:

Thank you for reply, I’ve installed that with composer.

composer require "wowza/wse-rest-library-php:dev-master"
Is this correct? (this is from git page)

I’ve checked that file and maked the exact fix, but still does not work.

Seems line 50 and 77 got some error
$this->port = (!is_null($port)) ? ($int)$port : $this->port;

Converted in
$this->port = (!is_null($port)) ? (int)$port : $this->port;

Lib to create a Stream Target get inside function 9 arguments.
In my case, if I need to configure an advanced stream target, I have to update that with cURL? Or have to extend lib?
For example if I need to configure an Akamai stream target, I can create the stream target with that but can’t add directly from API values as Akamai streamid.