Wowza Community

Wowza/Flex AV Chat example

I need to set up a videochat in my web site. I wonder if there is a new version of this piece of software and if it is possible to pass some values (ie server address and name of the users) to this Flex App.

All the best

Paolo Mazza

Hello Richard,

I have a question,where can I set all files of your project’s folder “wms-src” in the wowza server?

Hi Richard,

How to configure the file of conf/application.xml?



first off: I’ve tried out the avchat and it works like a charm – well done! Now that I set out to edit a few things, I stumbled across the error as well. The solution given above

The file is missing, sorry about that. You can grab it from the Flex SimpleVideoStreaming example.


Create this folder structure below the src folder of you Flex project:


And copy the file to there.


does not work for me – I followed the instructions, but get an error: a file in the source path must have the same package structure “com.meychi.ascrypt” as the package defined by “com.wowza.encryption.as3”. I am using flash builder 4. any hints?

cheers, jon

Hello I wanted to thank

You can have the fla to study it or ask too

Sorry but I do not understand but if I wanted to change the file avchat.swf.

I installed Flash Builder and would like to add a test image, but I do not know how to do

Sorry I downloaded flash builder premium 4 okay?

I can not figure out which version should I install Flex

I’m mad I can hardly understand you give me the link to download flex for windows?

Why flash fxp builder asks me the file?

Thank you and sorry

Excuse me because she gives me this error when creating swf

C:\Programmi\Adobe\Adobe Flash Builder 4\sdks\3.5.0\bin>mxmlc AVChat.mxml

Loading configuration file C:\Programmi\Adobe\Adobe Flash Builder 4\sdks\3.5.0\f


C:\Programmi\Adobe\Adobe Flash Builder 4\sdks\3.5.0\bin\ col:

42 Error: Accesso alla proprietÓ non definita TEA.“secureTokenResponse”, null, TEA.decrypt

(, sharedSecret));


C:\Programmi\Adobe\Adobe Flash Builder 4\sdks\3.5.0\bin\ col: 28

Error: Impossibile trovare la definizione com.meychi.ascrypt:TEA.

import com.meychi.ascrypt.TEA;


Thanks it does work you are very kind :slight_smile:

I ask because when I speak in the voice goes to two shots you can change values ​​by decreasing the video and increasing the voice

You can integrate text chat?

Thanks Thanks

Hello, I am still me … help

Thanks for help but I can not enter txtchat avchat

You can do a single mxml file txtchat avchat with a single connection using publishname

Thank you for your kindness

Hello I have a problem, I formatted the Wowza server I connect to a chat uesrs connected but do not see anyone even if I click on play

Sorry but I copied the jar file I rebooted Wowza server, but I do not see the user connected Wowza servers.


Thanks and sorry again

Configure logging: file:///C:/Program Files/Wowza Media Systems/Wowza Media Serv

er 2.2.3/conf/

INFO server server-start Wowza Media Server 2 Developer 2.2.3 build26454 -

INFO server comment - Serial number: XXXXX-XXXXX-XXXXX-XXXXX-GAVYA

INFO server comment - Maximum connections: 10

INFO server comment - Hardware Available Processors: 2

INFO server comment - Hardware Physical Memory: 377MB/1023MB

INFO server comment - Hardware Swap Space: 2105MB/2473MB

INFO server comment - Max File Descriptor Count: Unlimited

INFO server comment - OS Name: Windows 2003

INFO server comment - OS Version: 5.2

INFO server comment - OS Architecture: x86

INFO server comment - Java Name: Java HotSpot™ Client VM

INFO server comment - Java Vendor: Sun Microsystems Inc.

INFO server comment - Java Version: 1.6.0_24

INFO server comment - Java VM Version: 19.1-b02

INFO server comment - Java Spec Version: 1.6

INFO server comment - Java Home: C:\Program Files\Java\jre6

INFO server comment - Java Max Heap Size: 742MB

INFO server comment - Java Architecture: 32

INFO server comment - Java Encoding[file.encoding]: Cp1252

INFO server comment - Java Args[0]: -Xmx768M

INFO server comment - Java Args[1]:

INFO server comment - Java Args[2]: -Dcom.wowza.wms.AppHome=C:\Program

INFO server comment - Java Args[3]: Files\Wowza

INFO server comment - Java Args[4]: Media

INFO server comment - Java Args[5]: Systems\Wowza

INFO server comment - Java Args[6]: Media

INFO server comment - Java Args[7]: Server

INFO server comment - Java Args[8]: 2.2.3

INFO server comment - Java Args[9]: -Dcom.wowza.wms.ConfigURL=

INFO server comment - Java Args[10]: -Dcom.wowza.wms.ConfigHome=C:\Program

INFO server comment - Java Args[11]: Files\Wowza

INFO server comment - Java Args[12]: Media

INFO server comment - Java Args[13]: Systems\Wowza

INFO server comment - Java Args[14]: Media

INFO server comment - Java Args[15]: Server

INFO server comment - Java Args[16]: 2.2.3

INFO server comment - Java GC[0]: Copy

INFO server comment - Java GC[1]: MarkSweepCompact

INFO server comment - Server threads[h/t]: 10/10

INFO server comment - CMDInterface now listening: [any]:8083

INFO vhost vhost-start defaultVHost -

INFO server comment - defaultVHost threads[h/t]:120/80 home:C:\Program Files\W

owza Media Systems\Wowza Media Server 2.2.3

INFO vhost comment defaultVHost Bind attempt ([any]:1935:4)

INFO vhost comment defaultVHost Bind successful ([any]:1935)

INFO vhost comment defaultVHost Bind attempt ([any]:8086:1)

INFO vhost comment defaultVHost Bind successful ([any]:8086)

INFO server comment - Wowza Media Server is started!

ERROR server comment - loadModFunctions: java.lang.ClassNotFoundException: com.w


java.lang.ClassNotFoundException: com.wowza.wms.example.module.AVChat

at$ Source)

at Method)

at Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.Class.forName0(Native Method)

at java.lang.Class.forName(Unknown Source)

at com.wowza.wms.util.ModuleUtils.addModuleToApp(Unknown Source)

at com.wowza.wms.util.ApplicationUtils.loadModules(Unknown Source)

at com.wowza.wms.util.ApplicationUtils.loadConfigFile(Unknown Source)

at com.wowza.wms.application.ApplicationInstance.loadConfig(Unknown Sour


at com.wowza.wms.application.ApplicationInstance.(Unknown Source)

at com.wowza.wms.application.Application.getAppInstance(Unknown Source)

at com.wowza.wms.module.ModuleConnect.connect(Unknown Source)

at com.wowza.wms.request.RequestProcessFunctions.processFunctions(Unknow

n Source)

at com.wowza.wms.request.RTMPRequestAdapter.service(Unknown Source)

at com.wowza.wms.server.ServerHandler.serviceRequest(Unknown Source)

at com.wowza.wms.server.ServerHandler.handleMessageReceived(Unknown Sour


at com.wowza.wms.server.ServerHandler.messageReceived(Unknown Source)

at Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source


at java.util.concurrent.ThreadPoolExecutor$ Source)

at Source)

INFO application app-start definst avchat/definst

INFO session connect-pending -

INFO session connect -

INFO stream create - -

INFO stream publish sss -

INFO stream unpublish sss -

INFO stream destroy sss -

INFO session disconnect 1626413968 -

INFO application app-stop definst avchat/definst

Thanks I solved the problem but because I get this error?

And if I try to connect tells me connection closed

C:\flex\bin>mxmlc Avchat.mxml

Loading configuration file C:\flex\frameworks\flex-config.xml

C:\flex\bin\com\wowza\encryptionAS3\ col: 15 Warning: variable ‘p’ no

n contiene una dichiarazione di tipo.

for (var p = 0; p < n; p++) {


C:\flex\bin\com\wowza\encryptionAS3\ col: 15 Warning: variable ‘p’ no

n contiene una dichiarazione di tipo.

for (var p = n-1; p >= 0; p–) {


C:\flex\bin\AVChat.swf (272030 bytes)

Hello all ok because you have been kind


Hey rrlanham, thanks for this nice example

I got it running and it s doing fine, however, it seems i can’t have a list of the current connected users.

It was written somewhere that it was supposed to display users name (instead of clientId) but to do so there would need to be something like a login box, no ? I guess i m missing something there !

Publish this code on, please!

Hi Richard

After downloading your source set all files according your README.HTML in wowza server.suppose user1 pulish user1stream(streamname) and after this user2 publish user2stream(streamname).then in user1 side user1

show two stream user1stream and user2stream in listboxes.But video and microphone will play for user1stream not user2stream as user1 first publishes.

main problem is— stream which first publishes work for video and microphone.but other publishes stream not work for video and audio.

its very urgent…please help asap

There is a .jar file included with this example. Make sure you have have copied that to your Wowza /lib folder, and added the Module to the Application.xml, and re-started Wowza. Then each user should see the stream the other has published.


Hi rechard

Thanks for reply.need your help.

we have done everythings which are mentioned you.but this problem means— video and audio play for one stream which published first but video and audio does not play for other stream

means the problem

Lets suppose with user1 and user2. If user1 1st publish the a steam " steam1" and user2 publish another steam is “steam2”. But now if user2 select the user1 steam “steam1” then he/she can able to see the user1 video/audio and his own video. But user1 who 1st the create the steam he never see the user2 video/audio he(user1) .

please help…

Hi Rechard

Please help us… please check

you show the problem

we use rtmp address – rtmp://

is it wrong??

It didn’t load for me. I’m not sure what the problem could be. It is an as-is example. If you want to extend it and do not know Flash/Flex (Actionscript 3) you will have to look for a Flash and Wowza developer. We have a list of independent consultants that you can get by sending request to


Hi Richard

Thanks for reply.also we contact through mail

but facing one problem when publish stream by 2nd user,3rd user…

after stopping wowza server if we run bin/startup.bat in command prompt.then for publishing stream by user1 no licensing issue but for publishing stream by user2,user3… having licensing issue

issues are for user2,user3… Licensing[avchat/definst/guest_196964007]*** licence limit for publishing streams

publishing streams are stopped…