Wowza Community

Wowza high memory usage and stop working

Hello,

I have wowza 4.7.8 and Java Version 9.0.4

My JAVA setting is recommended:

Java Heap Size

Production level 10000 MB

Java Garbage Collection Settings

G1 (Garbage First) collector (recommended) -XX:+UseG1GC -XX:MaxGCPauseMillis=100

My Server have 4 cores and 16 GB of RAM

I only have 30 incoming streams without transcoder and recording

Every 2 days Memory is full and streaming is stop and I force to reboot the server.

I see many post on forum about memory usage and can not see a solution about in.

Are I must be increase the RAM or my tuning is wrong?

Please help me

Thank you for sharing all you have tried so far and it sounds like you have taken all the right steps to debug @Hasan Hameed Alhusseini. Because 4.7.8 has some pretty big changes in it, our engineers will need a support ticket to fully access your files and logs and get more info on your hardware.

They will then be able to try and reproduce what you are seeing and be able to suggest what needs to be done with tuning your system. It sounds like you have enough power, so the memory being cannot be determined from the forums.

You can submit it here and they are available on weekends. You will get a reply within 48 hrs at the very most. Thanks.

https://www.wowza.com/support/open-ticket

Request: can you state what the problem was and what solution was used? We will all know the problem and the solution.

We have been working since the beginning of its establishment. We’ve also recently updated to 4.7.8 and … We have been working since the beginning of its establishment. We also recently updated to 4.7.8 and … of course memory problem, CPU … but I anticipated that. Return to 4.7.7 and everything works without a problem.

In recent years, every update is … you have to wait for customers to make changes … then the scream begins … and problems with operation. It’s the same now.

My personal feeling - the wowza team is more focused on their CLOUD solution. I regret. It’s good that technical support works well.

SUGGESTION for FORUM - section where we can ONLY find problems reported with UPDATE to the new version and information on what solutions were used.

Thanks

Same problem

Hello

The best solution is Create ticket with wowza support team

But for users that have same problem, The support says that the wowza 4.7.8 has bug with mpeg dash when you do not use it. If you disable it from application manager this problem will be solved

I not have RAM problem for last 5 days.

Thanks for the feedback @Dorota Szafer-Kwasik and I will see if we can get the “upgrade questions” forum implemented. I think that’s a great idea- thanks.

The upgrades in 4.7.8 in Engine were for a lot reasons, but most of it as you know was due to potential security threats in using the old version of Java 8 and an older Winstone servlet container.

Upgrading such changes can potentially interfere with some custom applications or plugins users had configured in 4.7.7. Several customers upgraded without issue, but I am going to ask if engineering can offer some specific info here as you have requested.

We always welcome feedback like this from our customers and are listening.

It is very simple
no need to restart the server
If your server is linux then do cache clear

  1. free -h
  2. sudo sync; echo 3 > /proc/sys/vm/drop_caches
    then check again free -h

do it every day or 2 days once…

increase your ram to 32Gb later…

Plan to restart wowza every week or every month… not server machine only wowza
you do it by going to server setup…

Do this wowza will not get stop…

1 Like

Thanks @hari_hari for sharing this.

Some of you may also want to check out the following:

https://www.wowza.com/docs/how-to-create-a-java-heap-dump-on-wowza-streaming-engine

and

https://www.wowza.com/docs/tune-wowza-streaming-engine-for-optimal-performance