Wowza Community

Wowza, NVIDIA, Linux - Best driver version for NVENC transcoding


I have a Wowza 4.7.1 setup on a Debian 8 box with an Nvidia Quadro K4000

The most recent guide I have found about Nvidia Linux drivers was here:

I ran into a few non-wowza related issues and had to reinstall the graphics drivers and decided to update to the latest available (hoping it would resolve my other issue) That version is 384.59

However, when I did that I notice none of my streams started. There was nothing in the wowza error log during that time but once I rolled the driver back to 367.27 and it started working.

I noticed when on 384.59 I ran nvidia-smi and java did not show up in the running processes. This was a production server so I didn’t have much time to trial and error things.

So my question is, what is the latest, official, driver version for WSE 4.7.1?

Hello @Nathan Kadish,

Thanks for posting this issue.

It is quite concerning that the latest drivers are failing to function for you.

Have you tried to install the drivers first, and then install Wowza 4.7.1? (in other words, uninstall Wowza, then install new drivers, then install Wowza 4.7.1).

If the above gets you the same issue, we would need to take a further look in to the issue with your logs and conf folders. The best we is to submit a support ticket here so our support staff can take over and provider further assistance.


Alex C.