Wowza Community

WowzaStreamingEngine won't start after upgraded to 4.8.0

Hi,
I just upgraded wowza stream engine in my server from 4.7.7 to 4.8.0.
But now, the WowzaStreamingEngine won’t start.
If I check using /etc/init.d/WowzaStreamingEngine status, it always in stop status, when I check using systemctl status WowzaStreamingEngine, it said: active (exited)
After searching I found in one of the link saying that if I want to know more info, I better using startup.sh in the bin of Wowza installation directory, and when I using it, it gave me:

OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Unrecognized VM option ‘UseParNewGC’
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

Any ideas how can I solved the problem?

Thanks in advance for the help.

Here is the OS and Java in my server:

  • OS: Centos 7
  • Java: OpenJDK 11

There are other OpenJDK in my server, that is the OpenJDK 8, I change to OpenJDK 11 using alternatives -config java, when I issued the command: java -version it said:

openjdk version “11.0.6” 2020-01-14 LTS
OpenJDK Runtime Environment 18.9 (build 11.0.6+10-LTS)
OpenJDK 64-Bit Server VM 18.9 (build 11.0.6+10-LTS, mixed mode, sharing)

Hello @Sobari Tanuwijaya

Please try removing “UseParNewGC” in your [install-dir]/conf/Tune.xml to see if it resolves this issue.

If not, please use the below link to open a support ticket for further review:

https://www.wowza.com/support/open-ticket

-JasonT

Ah, so it should be in that file (Tune.xml).

I had check the file but the only UseParNewGC that exists is surround by the comment.
But I solve the problem by changing the 21 line from:

<GarbageCollector>${com.wowza.wms.TuningGarbageCollectorConcurrentDefault}</GarbageCollector>

to

<GarbageCollector>${com.wowza.wms.TuningGarbageCollectorG1Default}</GarbageCollector>

following the explanation above that line.
And now the Wowza run as it should be.

So, Jason, thank you very much for the help.