Wowza Community

Youtube Streaming Target

Hello Everyone,

I’m running into a problem when trying to stream to youtube via a stream target on wowza streaming engine. Previously using the classic live streaming setup from youtube, this worked flawlessly. Now that youtube has deprecated that product, I can not get the stream to start on its own without having to be in Youtube studio before starting the stream on the encoder. Is anyone else running into this, or have you found a fix for this problem?

Sorry to hear you are experiencing difficulties. There are no reported issues and we have several customers streaming to You Tube daily. I am assuming you followed this doc:

https://www.wowza.com/docs/how-to-stream-to-youtube


If you'd like us to review why this isn't working for you, please submit a support ticket where we'd be happy to review your configuration.

Hello have you tried putting on the Auto start button in the Youtube Studio panel?

Hi Egbert I’ve been looking for the auto start button in youtube studio but have not been able to find it. Can you send screenshots of where it is at? thank you

It on the right side of where you get the key. Its the first switch.

Egbert it looks like it is not there unless i setup a scheduled live stream which is not what i want to do for each event.

Hi Michael.

The Auto Start and Auto Stop are available when you schedule a stream using the “Manage Streams” button (third down on the left). Create the new stream (you will not see the option on the create page). After the new stream is saved, edit it, and you will see the option for auto start and auto stop. You do not have to have live control room open when the stream starts. It’s a pain now that you have to schedule EVERY stream, but at least you don’t have to be in YouTube when it starts.

Mike.

Mike do you know is this something that YouTube will be fixing or does Wowza need to make an change to adjust to the YouTube update?

1 Like

Hi, any wizard out there that can tell me why my Wowza live stream shows Active in WSE as Stream Target to YouTube, but doesn’t appear in YouTube Studio? Of course I added ModuleAddAudioTrack added to the live Application, because YouTube requires an audio track.

Hi @Peter_Austin do your logs show any errors/ hints or no because it’s showing as active in engine? I’m not sure if this is the Wowza article you followed, but you have to start the stream in You Tube Studio first, then in Engine. If you did that and don’t have any logs errors, we may need to get a support ticket to test it out.

Also, here is a troubleshooting tip page from You Tube if that helps you: says to check your codec is H264 with aac and check the bitrates, resolution, things like that…

https://support.google.com/youtube/answer/3006768?hl=en&ref_topic=6104880

I am using Wowza’s default sample.mp4 “Big Buck Bunny” as sound source, perhaps that is the problem? So sample.mp4 is not good to be used for YouTube.

I know understand it needs to be H.264 and AAC so sample.mp4 can’t be used as the audio module for YouTube?