Results 1 to 9 of 9

Thread: H.264 RTP video playback does not work in Flash player 11

  1. #1

    Default H.264 RTP video playback does not work in Flash player 11

    Flash Player 11 does not play H.264 RTP video stream if bufferTime=0
    Env: Windows7, Wowza3, Flash Player 11

    Some facts:

    1. Disabled hardware acceleration does not help.
    2. 10.3 player works ok.
    3. bufferTime=1 works with big delay 5-10 seconds

    Some additional links:

    Can wowza team fix this bug on wowza-side?

  2. #2


    From your link on the bug tracker it looks to be a Flash specific issue. Probably the best thing you can do is to post there and report your steps to reproduce.

    You can also try encoding in a different format that Flash supports. Sorenson, VP6, etc..

  3. #3
    Join Date
    Dec 2007


    If you increase the streams FPS it should start more quickly. Flash waits for about 60 frames before it displays h.264 video if buffer > 0.

    More info here:

    Last edited by rrlanham; 10-21-2011 at 06:49 AM.

  4. #4



    Thanks for the helpful info.
    It is really big problem for our low-latency application.

    Unfortunately we can not increase frame rate on encoder-side.
    Yes, i understand that it is Flash player issue, introduced in 11 version in Flash player.

    But, when Flash-client(or FMLE) encodes H.264 video and send it over RTMP - all works ok.

    I guess because:
    Unlike Flash Player 11 which generates one slice NALU (in H.264) per frame, the SIP endpoint generates multiple slice NALUs per frame. It generates (constrained) baseline profile for H.264. It does not generate access unit delimiter or SEI NALU.
    This means, incoming RTP stream may be transformed to Flash Player 11 compatible stream (one slice NALU per frame). It would be good workaround for this bug.

    I will vote this bug on adobe bug tracker.

    Another way to resolve this problem - using transcoder H.264 to H.264 one NALU per
    frame. Can i do it with wowza transcoder?

  5. #5


    Yes, the transcoder will generate a single SLICE NAL unit per-frame. If that is your question.


  6. #6
    Join Date
    May 2011



    This is in Adobe's Flash bugbase.

    Please go there and vote for it to be fixed.

    Live H264 with bufferTime=0 works on Flash Player 10.x, but fails when Player is upgraded to 11.0 or 11.1.
    Flash Player Beta 11.2 (incubator build) fixes problem, but 11.2 isn't scheduled for release until first half 2012, which could be as late as June.

    Problem is visible using examples/LiveVideoStreaming/clientOSMF.
    Problem is visible using examples/LiveVideoStreaming/clientFlex if you add the line:
    nsPlay.bufferTime = 0;
    before the line;


  7. #7


    Dealing with this stupid bug for a couple of hours... :/ However, problem is fixed within Flash Player ver. 11.2.202 Beta RC_1. It's also possible to set buffersize to zero again. For now, we implemented some nasty workaround in all our Flash-scripts which need rtmp for H.264, to handle any 11.x Flash version and set buffer to min 0.1 -> results with a delay of 1 sec, pretty uncool for lowlatency...


  8. #8


    Hi Drahomir,

    I see you've been using Wowza for quite a long time. Can you please clarify what the problem is? We take these reports seriously.

    I don't think you are experiencing the same error, since the bug tracker and the poster above your report this issue is resolved. Also, you are saying buffertime=0 works, but the issue in this thread is the opposite of that.

    In the other thread you had a file not found error:

    Are you saying your issue is resolved now?

  9. #9


    I'm retesting everything now. I've started with the notion that it must be something I messed up in Wowza because I don't know how to use it well, but it might be just down to flash player version.

    I'll repost as soon as I figure it out...

    Well, I figured it out:

    A weird version of flashplayer was in Chrome and Opera browsers. I installed the latest and it works: is ok and is the latest is ok and this is what Google Chrome installed automatically, since it does the fp updates withing its own updates.

    BUT, I still set the buffer at 0.

    If the buffer is over 0, (mp4 h264) videos don't play.

    I tried it with 0.1, 1 and 3.

    The older version was 11.1... something. It seems that it was refusing to take in the html object flashvars, so the wowza server was probably hitting a 404 type error.
    Last edited by Dragomir; 04-14-2012 at 02:24 AM.

Similar Threads

  1. Live adaptive bitrate playback with Flow Player - it does not work
    By michalm in forum Live Streaming and Encoder Discussion
    Replies: 5
    Last Post: 04-03-2014, 11:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts