Results 1 to 3 of 3

Thread: Encoder pushing rtp stream

  1. #1

    Default Encoder pushing rtp stream

    Hello
    I have been trying to use an encoder to push a rtp stream into Wowza but I'm receiving the error below ~every 3 seconds:
    PacketizerMPEGTS.handleRTPPacket: Out of sync: 0x80
    I Found a post that stated to try a different AV sync method, I tried all 3 types and still received the same error.

    My setup works fine with another encoder manufacturer pushing an rtp stream into Wowza.

    I was hoping there was a configurable item I could change to fix the error above or is it something the encoder is doing wrong when it creates the rtp stream.

    Thanks
    Austin

  2. #2
    Join Date
    Mar 2011
    Posts
    6

    Default

    I am also having this exact problem, I think I'm missing something very basic though.
    The encoder I'm trying is the Epiphan VGA2WIFI frame grabber, which can an RTP stream supposedly using MPEG-4 or h.264 codecs, no mention of MPEG-TS. It also has the option of sending the audio and video streams to different ports, and the option to do "h.264 slicing". (Complete noob here in case you were wondering.)

    Should I expect to see an option to encode/send MPEG-TS, and consider the device incompatible if not? Also, are there other RTP depacketizers available aside from MPEG-TS? I've followed the instructions here http://www.wowza.com/forums/content.php?37 , and I can include my Application.xml if that helps.

    Thanks much!

  3. #3
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    Use h.264.

    Don't use h.264 slicing

    It doesn't sound like mpegts encoder. Does it generate an SDP file? If so, follow this guide:

    http://www.wowza.com/forums/content....-with-SDP-file)

    Richard

Similar Threads

  1. Pushing continuous live meta data from swf encoder to player
    By rajdeeprath in forum Live Streaming and Encoders
    Replies: 8
    Last Post: 03-28-2014, 01:23 PM
  2. RTMP Security over SSL while pushing from encoder
    By duxmedia in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 06-24-2013, 07:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •