Results 1 to 4 of 4

Thread: Transcoder 3.02/3.03 and w2008r2 standard dual xeon x5675

  1. #1
    Join Date
    May 2011
    Posts
    13

    Default Transcoder 3.02/3.03 and w2008r2 standard dual xeon x5675

    Hi.

    Trying to get the transcoder running and having issues getting it to fly. Removing the "transcoder" value from the xml makes the stream work so the server seems to be running fine. Mad a dependency walkthrough on the libogdll that it complains about, and saw that it was looking for msvcr90.dll, which was not installed (msvcr100.dll was there), installed the c++ redist and the msvcr90 got installed. After that it stopped complaining about that but gives the following message when a livestream connects:
    Server log:
    INFO server comment - TranscoderSessionNative.loadLibrary: Load transcoder list:
    C:/Program Files (x86)/Wowza Media Systems/Wowza Media Server 3.0.2/lib-native/
    win64/transcoder.list Exception in thread "VHostHandler._defaultVHost_.74" java.lang.UnsatisfiedLinkError: C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.0.2\lib-native\win64\libogg.dll: The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail

    Dependency:
    Error: The Side-by-Side configuration information for "c:\program files (x86)\wowza media systems\wowza media server 3.0.2\lib-native\win64\LIBOGG.DLL" contains errors. The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail (14001).
    Error: At least one module has an unresolved import due to a missing export function in an implicitly dependent module.
    Error: Modules with different CPU types were found.


    SXStool:
    =================
    Begin Activation Context Generation.
    Input Parameter:
    Flags = 0
    ProcessorArchitecture = AMD64
    CultureFallBacks = en-US;en
    ManifestPath = C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.0.2\lib-native\win64\libogg.dll
    AssemblyDirectory = C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.0.2\lib-native\win64\
    Application Config File =
    -----------------
    INFO: Parsing Manifest File C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.0.2\lib-native\win64\libogg.dll.
    INFO: Manifest Definition Identity is (null).
    INFO: Reference: Microsoft.VC90.CRT,processorArchitecture="amd64",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",vers ion="9.0.21022.8"
    INFO: Resolving reference Microsoft.VC90.CRT,processorArchitecture="amd64",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",vers ion="9.0.21022.8".
    INFO: Resolving reference for ProcessorArchitecture amd64.
    INFO: Resolving reference for culture Neutral.
    INFO: Applying Binding Policy.
    INFO: No publisher policy found.
    INFO: No binding policy redirect found.
    INFO: Begin assembly probing.
    INFO: Did not find the assembly in WinSxS.
    INFO: Attempt to probe manifest at C:\Windows\assembly\GAC_64\Microsoft.VC90.CRT\9.0.21022.8__1fc8b3b9a1e18e3b\Microsoft.VC90.CRT.DLL.
    INFO: Attempt to probe manifest at C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.0.2\lib-native\win64\Microsoft.VC90.CRT.DLL.
    INFO: Attempt to probe manifest at C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.0.2\lib-native\win64\Microsoft.VC90.CRT.MANIFEST.
    INFO: Attempt to probe manifest at C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.0.2\lib-native\win64\Microsoft.VC90.CRT\Microsoft.VC90.CRT.DLL.
    INFO: Attempt to probe manifest at C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.0.2\lib-native\win64\Microsoft.VC90.CRT\Microsoft.VC90.CRT.MANIFEST.
    INFO: Did not find manifest for culture Neutral.
    INFO: End assembly probing.
    ERROR: Cannot resolve reference Microsoft.VC90.CRT,processorArchitecture="amd64",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",vers ion="9.0.21022.8".
    ERROR: Activation Context generation failed.
    End Activation Context Generation.

    Any help is appreciated.

  2. #2
    Join Date
    May 2011
    Posts
    13

    Default

    Patching the machine to SP1 doesn´t help.

  3. #3
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Can you zip up conf, logs and transcoder folders and send them to support@wowza.com

    Include a link to this thread.

    Richard

  4. #4
    Join Date
    May 2011
    Posts
    13

    Default

    Solved it with the help of charlie. Looks like you needed the .net framework 3.5.1 to be able to run.

Similar Threads

  1. Does the standard Transcoder meet my requirements?
    By tiger.tian in forum Wowza Streaming Engine functionality
    Replies: 1
    Last Post: 06-13-2013, 03:56 AM
  2. Transcoding/restreaming a non-standard stream?
    By bfinleyui in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 05-22-2012, 03:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •