Results 1 to 4 of 4

Thread: Live streaming broadcast from WireCast on Mac

  1. #1

    Default Live streaming broadcast from WireCast on Mac

    I'm using the information contained in the Telestream Wirecast live encoder with Wowza Server article. I want to stream a live broadcast to iPads. This article says to use one of the flash encoders to send the stream. This works but it also says to edit the H.264 encoder settings. Why is this necessary. I assume that the Wowza server uses the Flash encoded stream to create all the other streams necessary for the various devices. In our case we only need the http stream for the iPads. When I tried this with the WMS2 version whenever I would link to the url it would stop the cupertino stream.
    From log...
    2011-10-05 09:02:03 PDT create stream INFO 200 myStream.sdp - _defaultVHost_ live _definst_ 0.0010 209.53.143.43 1935 http://209.53.143.43:1935/live/myStr.../playlist.m3u8 174.7.191.142 http (cupertino) - Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7 1351391039 0 0 31 0 0 0 myStream.sdp - - - - - http://209.53.143.43:1935/live/myStr.../playlist.m3u8 http://209.53.143.43:1935/live/myStr.../playlist.m3u8 - http://209.53.143.43:1935/live/myStr.../playlist.m3u8 -
    2011-10-05 09:02:03 PDT comment server WARN 200 - HTTPStreamerAdapterCupertinoStreaming.getAppInstance: Stream not found [live/myStream.sdp/playlist.m3u8]: myStream.sdp - - - 142549.333

  2. #2
    Join Date
    Sep 2011
    Posts
    1,920

    Default

    Hi
    The configuration of the stream needs to be: (baseline: 3.0, Audio: AAC/mp3, Video: H.264)

    There is a tutorial here,
    http://www.wowza.com/forums/content....-based-encoder)

    Jason

  3. #3

    Default

    Okay. I have the Wowsa server running on an xServe running Lion at http://209.53.143.43:1935/live/myStr.../playlist.m3u8. When I link to this in my Safari browser on my iMac it attempts to download and launches iTunes. If I link to it with QuickTime Player it never stops trying to load the movie. If I link with an iPad it kills the stream.
    INFO server comment - LiveStreamPacketizerCupertino.endChunkTS[live/_definst_/myStream.sdp]: Add chunk: id:10 a/v/k:105/0/0 duration:10080
    INFO cupertino connect 968352553 -
    INFO stream create myStream.sdp -

  4. #4
    Join Date
    Sep 2011
    Posts
    1,920

    Default

    Hi
    When you start Encoding your logs should tell you what's going on.
    Can you post the logs from when you connect your encoder please.

    Jason

Similar Threads

  1. x264 - Sync Issues - Both Mac & Windows - Wirecast 5
    By marcosfigueroa in forum Live Streaming and Encoders
    Replies: 1
    Last Post: 02-12-2014, 07:52 AM
  2. wowza / wirecast / ffmpeg not detecting end of broadcast
    By optics in forum Live Streaming and Encoder Discussion
    Replies: 2
    Last Post: 12-19-2012, 10:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •