Results 1 to 7 of 7

Thread: average segment bitrate is too high (worried abouat appstore rejection)

  1. #1

    Default average segment bitrate is too high (worried abouat appstore rejection)

    I have an audio only stream that media info is reported is correct, but apple's media validation tool is reporting too high. This is using the latest version of 3.0.3. Help..

    mediainfo /movies/0/1/1_the_cat_and_the_canary_0_64_FILM_v2.mp4
    General
    Complete name : /movies/0/1/1_the_cat_and_the_canary_0_64_FILM_v2.mp4
    Format : MPEG-4
    Format profile : Base Media
    Codec ID : isom
    File size : 37.4 MiB
    Duration : 1h 19mn
    Overall bit rate : 65.4 Kbps
    Encoded date : UTC 2009-11-29 00:00:00
    Tagged date : UTC 2009-11-29 00:00:00
    Writing application : Lavf53.20.0

    Audio
    ID : 1
    Format : AAC
    Format/Info : Advanced Audio Codec
    Format version : Version 4
    Format profile : LC
    Format settings, SBR : No
    Codec ID : 40
    Duration : 1h 19mn
    Bit rate mode : Variable
    Bit rate : 62.4 Kbps
    Maximum bit rate : 64.0 Kbps
    Channel(s) : 2 channels
    Channel positions : Front: L R
    Sampling rate : 48.0 KHz
    Compression mode : Lossy
    Stream size : 35.7 MiB (95%)
    Language : English
    Encoded date : UTC 2009-11-29 00:00:00
    Tagged date : UTC 2009-11-29 00:00:00


    --------------------------------------------------------------------------------
    /app/_definst_/mp4:0/1/1_the_cat_and_the_canary_0_64_FILM_v2/playlist.m3u8?wowzasessionid=21695796
    --------------------------------------------------------------------------------

    Playlist Validation:

    OK

    Segments:

    OK

    Average segment duration: 9.98 seconds
    Average segment bitrate: 134.60 kbits/s

  2. #2

    Default

    When I take my audio only mp4 (which I've now encoded at 48K) and run apples mediafilesegmenter on it I get:

    Nov 12 2011 15:46:35.396: average bit rate is 49575.9 - max file bit rate is 57681.2

    However, when I deply that to my wowza and run mediastreamvalidator on that same stream I get:

    Average segment duration: 10.00 seconds
    Average segment bitrate: 102.66 kbits/s

    WHY is the average segment bitrate so different coming from Wowza? This is with 3.0.3.
    Last edited by danaronson; 11-12-2011 at 05:25 PM. Reason: updated info

  3. #3

    Default

    Are you including album art or any metadata? Is there anything extra in the stream?

    Charlie

  4. #4

    Default

    no, and the weird thing is that if I use wget to get the segments then the bitrates seem to be correct. However I'm finding it hard to believe that the stream validation tool can be so off, so I'm wondering what else might be happening.

  5. #5

    Default

    I am going to point at the tool. You may want to contact Apple support.

    Charlie

  6. #6

    Default

    I've entered a bug report, but is it possible for you too see if wowza is doing anything wrong here?

  7. #7

    Default

    and they fixed their tool (but that are still charging me $50 for bringing it to their attention), some racket they have going....

Similar Threads

  1. Replies: 44
    Last Post: 11-09-2010, 01:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •