Results 1 to 8 of 8

Thread: MediaStreamMap.addLicense exception

  1. #1

    Default MediaStreamMap.addLicense exception

    I am using Wowza3.0.3 on windows7.
    The server boots up normally and it correctly prints my licence number in the beginning

    2011-11-16 17:04:18 EET comment server INFO 200 - Server License Key: SVRB3-XXXXX-XXXXX-XXXXX-XXXXX-vBf44

    However when i try to start a stream i get

    2011-11-16 17:05:46 EET comment server INFO 200 - MediaStreamMap.addLicense[new]: java.lang.NumberFormatException: For input string: "8ݢ - - - 87.82 - - - - - - - - - - - - - - - - - - - - - - - - -
    2011-11-16 17:05:46 EET comment server WARN 200 - Licensing[vms/_definst_/3-Camera3.vmsx]: *** Hit license limit for publishing streams. Publishing stream is stopped. *** - - - 87.821 -

    I have rechecked the licence file, I have only a single developer licence.
    The licence number is printed in the first line and there is also a new line at the end.
    I removed the newline and retried with the same result.

    What could be the problem?

    Thanks
    Özgür

  2. #2
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Özgür,

    It's a license limitation of the developer license.

    Richard

  3. #3

    Default Developer license limitation

    Richard,

    Do you mean that i cant even start a single live stream with the developer license?
    I thought the limit was 10 live streams.

    Ozgur

  4. #4
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Ozgur,

    It is 1 stream in and up to 9 out in the developer edition

    http://www.wowza.com/developer.html

    Richard

  5. #5

    Default Licence Issue

    Dear Richard,

    This is not a developer license issue.
    In our company we also have monthly subscriber license.
    I tried with that license and the result is the same.
    I was expecting this since in my previous post i have sent the error

    "MediaStreamMap.addLicense[new]: java.lang.NumberFormatException: For input string: "8ݢ - - - 87.82"

    This seems to indicate that somehow wowza is not able to read the license file.

    Someone suggested that this might be a 64 bit JVM issue.
    I have a 64 bit JVM. Developers in our company who have 32 bit JVM are not running into
    this problem.

    Regards,
    Özgür

  6. #6

    Default

    Hi Özgür,

    That's a good tip about the 32-bit. I have a feeling it's a file encoding issue with your server.license file. I see that the input string is about half the number of bytes as the Wowza license. Possibly, you're using UTF-16 instead of the default UTF-8 (in debian). Check your locale, and ensure that you're using the same file encoding as the working systems.

  7. #7

    Default Licence Issue

    Unfortunately switching to 32 bit JVM or changing the file encoding to UTF-8 did not work.
    I still get the

    MediaStreamMap.addLicense[new]: java.lang.NumberFormatException: For input string: "B7Ä°1H"

    error.

    This really looks like an encoding problem. But I am out of ideas.

    Please Help.
    Özgür

  8. #8
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    Maybe it is not plain text?

    If you haven't got this, zip up conf and logs and send them to support@wowza.com with a link to this thread for reference

    Richard

Similar Threads

  1. nDVR Exception
    By ozgurdeniz in forum AddOn: Wowza nDVR
    Replies: 3
    Last Post: 04-09-2013, 07:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •