Results 1 to 5 of 5

Thread: NullPointerException on downrate webcam video

  1. #1

    Default NullPointerException on downrate webcam video

    Hi everybody!
    I trying to solve the trivial problem. I want transcode video on webcam for make two stream - original (source) and low downrate (128kbs).
    Im enabled transcoder in Application.xml, editing transrate.xml and more-more needed action )))
    But i have this error


    INFO 200 - TranscoderSessionNative.loadLibrary: Load transcoder list: C:/Program Files (x86)/Wowza Media Systems/Wowza Media Server 3.0.3/lib-native/win64/transcoder.list
    INFO 200 - LiveStreamTranscoder.init[twonets/_definst_/DemonHunter]: Load transcoder template: file:///C:/Program Files (x86)/Wowza Media Systems/Wowza Media Server 3.0.3/transcoder/templates/transrate.xml
    INFO 200 - JNI:TranscoderSession.isCUDAAvailable[twonets/_definst_/DemonHunter]: NVidia CUDA hardware acceleration is NOT available
    INFO 200 - JNI:TranscoderSession.isQuickSyncAvailable[twonets/_definst_/DemonHunter]: Intel Quick Sync hardware acceleration is NOT available
    INFO 200 - onStreamCreate - - -
    INFO 200 - - - - -
    INFO 200 - ON PUBLISH DemonHunter_source -
    ERROR 500 - TranscoderSessionDestination.init[twonets/_definst_/DemonHunter]: [DemonHunter_source]:java.lang.NullPointerException

    Senx for all answer.
    Last edited by AlexZvukoff_USSR; 11-24-2011 at 04:27 AM.

  2. #2
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    What is the source? Looks like it is unreachable, perhaps.

    Is the StreamType set to "live"?

    Need more details.

    Richard

  3. #3

    Default

    Richard, senx for reply.

    "source" its simple video publish on Wowza (use netStream.publish("DemonHunter","live") ) from flash-client application. Yes, im use StreamType "live".

    My Application.xml in /conf/myApp/

    <Root>
    	<Application>
    		<Connections>
    			<AutoAccept>true</AutoAccept>
    			<AllowDomains></AllowDomains>
    		</Connections>
    		<Streams>
    			<StreamType>live</StreamType>
    			<StorageDir>${com.wowza.wms.context.VHostConfigHome}/content</StorageDir>
    			<LiveStreamPacketizers>cupertinostreamingpacketizer, smoothstreamingpacketizer, sanjosestreamingpacketizer</LiveStreamPacketizers>
    			<Properties>
    			</Properties>
    		</Streams>
    		<Transcoder>
    			<LiveStreamTranscoder>transcoder</LiveStreamTranscoder>
    			<Templates>${SourceStreamName}.xml,transrate.xml</Templates>
    			<ProfileDir>${com.wowza.wms.context.VHostConfigHome}/transcoder/profiles</ProfileDir>
    			<TemplateDir>${com.wowza.wms.context.VHostConfigHome}/transcoder/templates</TemplateDir>
    			<Properties>
    			</Properties>
    		</Transcoder>
    		
    		<SharedObjects>
    			<StorageDir></StorageDir>
    		</SharedObjects>
    		<Client>
    			<IdleFrequency>-1</IdleFrequency>
    			<Access>
    				<StreamReadAccess>*</StreamReadAccess>
    				<StreamWriteAccess>*</StreamWriteAccess>
    				<StreamAudioSampleAccess>*</StreamAudioSampleAccess>
    				<StreamVideoSampleAccess>*</StreamVideoSampleAccess>
    				<SharedObjectReadAccess>*</SharedObjectReadAccess>
    				<SharedObjectWriteAccess>*</SharedObjectWriteAccess>
    			</Access>
    		</Client>
    		<RTP>
    			<Authentication>
    				<PublishMethod>digest</PublishMethod>
    				<PlayMethod>none</PlayMethod>
    			</Authentication>
    			<AVSyncMethod>senderreport</AVSyncMethod>
    			<MaxRTCPWaitTime>12000</MaxRTCPWaitTime>
    		</RTP>
    		<HTTPStreamers>sanjosestreaming</HTTPStreamers>
    		<MediaCaster>
    			<Properties>
    			</Properties>
    		</MediaCaster>
    		<Modules>
    			<Module>
    				<Name>base</Name>
    				<Description>Base</Description>
    				<Class>com.wowza.wms.module.ModuleCore</Class>
    			</Module>
    			<Module>
    				<Name>properties</Name>
    				<Description>Properties</Description>
    				<Class>com.wowza.wms.module.ModuleProperties</Class>
    			</Module>
    			<Module>
    				<Name>logging</Name>
    				<Description>Client Logging</Description>
    				<Class>com.wowza.wms.module.ModuleClientLogging</Class>
    			</Module>
    			<Module>
    				<Name>myApp</Name>
    				<Description>myApp</Description>
    				<Class>com.wowza.wms.plugin.myApp</Class>
    			</Module>
    		</Modules>
    		<Properties>
    		</Properties>
    	</Application>
    </Root>
    Also, i disable all transrate options in transrate.xml except default transrate options

    <Root>
    	<Transcode>
    		<Encodes>
    			<!-- Example Encode block for source, not required unless Member of StreamNameGroup. --> 
    			<Encode>
    				<Enable>true</Enable>
    				<Name>source</Name>
    				<StreamName>mp4:${SourceStreamName}_source</StreamName>
    				<Video>
    					<!-- H.264, PassThru -->
    					<Codec>PassThru</Codec>
    					<Bitrate>${SourceVideoBitrate}</Bitrate>
    					<Parameters>
    					</Parameters>
    				</Video>
    				<Audio>
    					<!-- AAC, PassThru -->
    					<Codec>PassThru</Codec>
    					<Bitrate>${SourceAudioBitrate}</Bitrate>
    				</Audio>
    				<Properties>
    				</Properties>
    			</Encode>
    Another block in transrate.xml set "false". <Decode> and <StreamNameGroups> use default settings.

    Ready to answer any questions, please help me solve this... (

    P.S.: "Looks like it is unreachable" why im may test this? Application worked correctly! Client can publish and unpublish stream, open and close stream of another user and etc.
    Last edited by AlexZvukoff_USSR; 11-28-2011 at 06:55 AM.

  4. #4
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    Take a look at this article which includes a simple transcode template. Start with that.

    http://www.wowza.com/forums/content....across-clients

    Make sure you are setting audio to Speex.

    btw, the 2nd arg or NetStream.publish can be "record" or "append", which works with StreamType "default" (see VideoRecording example). Using "live" in this place has no meaning, but is not a problem either.

    Richard

  5. Default

    I got exactly the same error message. Using proprietary Flex client to publish audio/video to Wowza and followed the example as outlined in the article referred to in the previous post in this thread. Using SPEEX, default Application.xml with StreamType Live and the default audioonly.xml

    Yet ...

    #Version: 1.0
    #Start-Date: 2013-10-27 18:46:27 EDT
    #Software: Wowza Media Server 3.6.2 build5334
    #Date: 2013-10-27
    #Fields: x-severity x-category x-event date time c-client-id c-ip c-port cs-bytes sc-bytes x-duration x-sname x-stream-id x-spos sc-stream-bytes cs-stream-bytes x-file-size x-file-length x-ctx x-comment
    ERROR server comment 2013-10-27 18:47:25 - - - - - 57.603 - - - - - - - - TranscoderSessionDestination.init[bbb/_definst_/myTestStreamName]: [myTestStreamName_aac]:java.lang.NullPointerException
    WARN server comment 2013-10-27 18:47:33 - - - - - 65.59 - - - - - - - - CupertinoPacketHandler.handleHolder[bbb/_definst_/183f0bf3a0982a127bdb8161e0c44eb696b3e75c-1382909158140_zhbpdbmjpvhp]: Invalid audio codec for iPhone/iPod:SPEEX
    What happens in TranscoderSessionDestination.init and TranscoderSessionDestination.shutdown that causes a NullPointerException? (Yes, the same error happens in shutdown)

    Wowza 3.6.2 build 5334
    Last edited by karelboek; 10-27-2013 at 04:00 PM. Reason: Added Wowza Version

Similar Threads

  1. Webcam recording using html5 <video>?
    By fjckls in forum General Forum
    Replies: 13
    Last Post: 07-02-2015, 02:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •