Results 1 to 2 of 2

Thread: adaptive for Silverlight using smil on Wowza/EC2

  1. #1
    Join Date
    Mar 2009
    Posts
    16

    Default adaptive for Silverlight using smil on Wowza/EC2

    Following the directions in this tutorial, I've created bigbuckbunny.smil:
    <smil>
        <head>
        </head>
        <body>
            <switch>
                <video src="mp4:bigbuckbunny_450.mp4" system-bitrate="450000"/>
                <video src="mp4:bigbuckbunny_750.mp4" system-bitrate="750000"/>
                <video src="mp4:bigbuckbunny_1100.mp4" system-bitrate="1100000"/>
                <video src="mp4:bigbuckbunny_1500.mp4" system-bitrate="1500000"/>
            </switch>
        </body>
    </smil>
    When attempting to play the following url:
    http://server on ec2:1935/vods3/_definst_/smil:amazons3/bucketname/smil:bigbuckbunny.smil/Manifest (and a few variations)
    the test player returns:
    "Streaming Error: Caught exception trying to parse main manifest: At least one media stream is needed, none are declared in the manifest."

    I've tried
    <video src="mp4:https://s3.amazonaws.com/bucketname/bigbuckbunny_450.mp4" system-bitrate="450000"/>
    with the same result.

    Any guidance much appreciated!
    Last edited by sethbb; 11-25-2011 at 05:07 PM.

  2. #2
    Join Date
    Mar 2009
    Posts
    16

    Default

    Never mind - found the problems. First was permissions on the smil and assets in the S3 bucket, then reverted to the original urls in the smil file and life is good!

    Oh, the proper url to put in the player is:
    http://myinstance:1935/vods3/_defins....smil/Manifest
    for anyone experiencing same issues.

Similar Threads

  1. SMIL URL for adaptive streaming not working from an iPAD
    By w_video_u in forum On-Demand Streaming
    Replies: 4
    Last Post: 05-01-2014, 08:59 AM
  2. Adaptive bitrate streaming - Smil file
    By elhal82 in forum Live Streaming and Encoder Discussion
    Replies: 0
    Last Post: 04-11-2013, 04:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •