Results 1 to 6 of 6

Thread: Restreaming RTMP to iOS - intermittent failure

  1. #1
    Join Date
    Dec 2011
    Posts
    4

    Default Restreaming RTMP to iOS - intermittent failure

    Hi Folks

    We're restreaming a live RTMP stream from a CDN to iOS devices.

    Everything works - for a while (2 hours today) but then we're getting the dreaded "The Operation Could Not be Completed" on iPhones & pads.

    Here's the setup.

    * EC2 Small instance with a community Wowza 3 AMI
    * Latest patches from the 'Production Builds' applied
    * Wirecast encoder (H.264 baseline, 600kbps, 64 mono audio AAC). Adjusted keyframes to get chunks of 4s or less.
    * Publishing to Edgecast and pulling the resultant RTMP stream into Wowza using the stream manager. Flash stream is rock solid.
    * Application XML is the standard provided with the AMI with the FCSubcribe call added.

    Nothing in the logs that we can see other than the final entry when we stopped getting access.

    HTTPStreamerAdapterCupertinoStreamer.service: Request timeout: 8000

    Let me know what other info you need. I can zip up all the conf, logs, trans & application.xml and send .. just not sure where to send right now.

    Stream will be running for the next 5 hours or so.

    Thanks

  2. #2
    Join Date
    Dec 2011
    Posts
    4

    Default Bit more info...

    Logs updated and there's some new info available.

    Getting this error stacking up (XXXX is our account ID so removed)

    NetConnectionConnection.connect: Failed to connect[fml.XXXX.edgecastcdn.net:1935]: org.apache.mina.common.RuntimeIOException: Failed to get the session[ConnectException: Connection refused].

    We know the connection worked previously (and does currently).

  3. #3
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    This indicates a network issue, something temporary from what you report, but enough to cause the problem

    Richard

  4. #4
    Join Date
    Dec 2011
    Posts
    4

    Default

    Hi Richard

    Thanks for the pointer. When you say network issue should we be looking at Edgecast or the EC setup to see if we can improve reliabilty?

  5. #5
    Join Date
    Dec 2007
    Posts
    21,962

    Default

    I misread that, it is an authentication problem: "Connection refused".

    Richard

  6. #6
    Join Date
    Dec 2011
    Posts
    4

    Default

    Hi Richard

    Thanks again for the tip. So if I'm understanding right the EC Wowza isn't able to pick up the stream because the connection is being refused by Edgecast?

    Odd - the stream is unprotected so the only thing I can think of is the FCSubscribe call is being missed.

    We'll keep trying!

Similar Threads

  1. iOS HTTP streaming playback failure
    By grossum in forum Live Streaming and Encoder Discussion
    Replies: 4
    Last Post: 12-05-2013, 11:54 PM
  2. Problem restreaming Axis IP camera to iOS - mediastreamvalidator errors
    By Daniel6 in forum Live Streaming and Encoder Discussion
    Replies: 3
    Last Post: 11-14-2013, 08:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •