Results 1 to 4 of 4

Thread: cannot play SMIL file in STB using ASX file

  1. #1
    Join Date
    Nov 2011
    Posts
    3

    Default cannot play SMIL file in STB using ASX file

    I use an SMIL file embedded within an ASX file to stream a few mp4 videos through the Set Top Box. The wowza logs shows the following error. Please help me out.

    HTTPStreamerCupertinoIndexPlaylist.indexFile[loopvideo/_definst_/smil:streamschedule.smil]: Playlist file is empty. Entries must be of the form: /smil/body/switch/video

    Thanks!

  2. #2
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    Are you mixing up the smil file used in the Stream class scheduler with multi-bitrate smil?

    Richard

  3. #3
    Join Date
    Nov 2011
    Posts
    3

    Default

    Hello rrlanham,

    Sorry for late reply.

    Yes, I am using Stream class example with playlists and schedules set in smil file but not with multi-bitrate.

    Thanks!

  4. #4
    Join Date
    Dec 2007
    Posts
    22,013

    Default

    The messages you show indicate that you are trying to play the schedule.smil as you would a multi-bitrate file, which does not work. The schedule.smil runs when Wowza starts, it starts other streams (e.g. "Stream1" in the example) that you will play in the client.

    Richard

Similar Threads

  1. SMIL file where should it be located?
    By Lars_Borg in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 05-13-2014, 08:31 PM
  2. http(hls) streaming with smil file to refer 1 mp4 file ( multi-cahannels )
    By qstream in forum Video On Demand Streaming Discussion
    Replies: 4
    Last Post: 10-26-2013, 12:52 AM
  3. Replies: 12
    Last Post: 10-25-2013, 04:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •