Results 1 to 5 of 5

Thread: Starting Wowza server

  1. #1
    Join Date
    Nov 2010
    Posts
    2

    Unhappy Starting Wowza server

    When I run startup.bat I get the following errors:

    Picked up JAVA_TOOL_OPTIONS: -agentlib:jvmhook
    Picked up _JAVA_OPTIONS: -Xrunjvmhook -Xbootclasspath/a:C:\PROGRA~2\QUICKT~2\bin
    \JAVA_S~1\classes;C:\PROGRA~2\QUICKT~2\bin\JAVA_S~1\classes\jasmine.jar
    Error occurred during initialization of VM
    Could not find agent library jvmhook on the library path, with error: %1 is not
    a valid Win32 application


    David

  2. #2

    Default

    I am not sure what that is. Wowza Server does not set any of those java options. It seems like a installation error or maybe a different startup.bat script is being run. How are you running startup.bat.

    You might try opening a command prompt and entering the following commands:

    cd %WMSAPP_HOME%\bin
    %WMSAPP_HOME%\bin\startup.bat
    See if that works.

    Charlie

  3. #3
    Join Date
    Nov 2010
    Posts
    2

    Unhappy Cannot start Wowza server

    I am running startup.bat from the application's bin directory as you can see here.

    C:\Users\David>cd C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server
    3.0.3\bin

    C:\Program Files (x86)\Wowza Media Systems\Wowza Media Server 3.0.3\bin>startup
    Picked up JAVA_TOOL_OPTIONS: -agentlib:jvmhook
    Picked up _JAVA_OPTIONS: -Xrunjvmhook -Xbootclasspath/a:C:\PROGRA~2\QUICKT~2\bin
    \JAVA_S~1\classes;C:\PROGRA~2\QUICKT~2\bin\JAVA_S~1\classes\jasmine.jar
    Error occurred during initialization of VM
    Could not find agent library jvmhook on the library path, with error: %1 is not
    a valid Win32 application


    David

  4. #4

    Default

    David,

    Try removing the env vars in dos and then running Wowza. i.e., Navigate to your Wowza bin directory in DOS then do:

    set JAVA_TOOL_OPTIONS=
    set _JAVA_OPTIONS=
    startup.bat
    This is not a Wowza error as Charlie mentioned. But, it looks like you installed a program called JASMINE which set the env vars, but now the Jasmine .jar doesn't exist.

  5. #5

    Default

    Thanks for the help.

Similar Threads

  1. Replies: 2
    Last Post: 10-07-2013, 08:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •